[Nightly] Geographic Reannotation did not update schematic

I’m using a nightly [version below]
I tried the geographical reannotation, the board updated but the schematic did not. Now I have a perfectly good board and schematic where the Ref designators don’t match.

I’ll just go back a rev or two and not reannotate unless someone knows how to force them to sync.

John

Application: KiCad PCB Editor

Version: (5.99.0-9910-g9a13835f5d), release build

Libraries:
wxWidgets 3.0.5
libcurl/7.71.0 OpenSSL/1.1.1g (Schannel) zlib/1.2.11 brotli/1.0.7 libidn2/2.3.0 libpsl/0.21.0 (+libidn2/2.3.0) libssh2/1.9.0 nghttp2/1.41.0

Platform: Windows 10 (build 19041), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Mar 21 2021 10:01:49
wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.73.0
OCE: 6.9.1
Curl: 7.71.0
ngspice: 34
Compiler: GCC 10.2.0 with C++ ABI 1014

Build settings:
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=OFF
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
KICAD_USE_OCE=ON
KICAD_SPICE=ON

Normally KiCad does not use the RefDes to sync between Eeschema and Pcbnew, but it uses “timestamps”, which have evolved into UUID’s for V5.99. If you did not now that, then now is a good moment to get some experience with that and various sync methods.

1 Like

You should be able to run “Update Schematic from PCB” from eeschema to fix this issue. We are working on the bug now. If you find an earlier working version, please let us know which one works correctly.

I ended up doing some things manually. Although I have no proof it seems like the “back annotation” did not like parts originally duplicated in the original schematic.

I’ll try again “after I save the current good version”

John