Nightly build; Zone on Dwgs.User layer

I am trying to add some documentation to my layout, and I put a zone on the Dwgs.User layer. But I notice a couple of visibility quirks:

  1. Visibility of that zone does not follow when I toggle visibility of the layer. Yes it does follow when I turn zone visibility on and off. I have text and also tried a circle on Dwgs.User layer, and those do follow when I toggle visibility of the layer.

  2. Even when Dwgs.User is the active layer, the zone is obscured by footprints and copper etc. on other visible layers. The circle and the text are “in front” when the Dwgs.User layer is active and get obscured when other layers are active…

Is this all correct?

Even if this is a minor bug it is not a serious problem. I am reluctant to change builds because I am working at the moment and this build is doing pretty well for me.

Thanks

Application: KiCad

Version: (5.99.0-2908-g9a4f92dfd9), release build

Libraries:
wxWidgets 3.0.5
libcurl/7.71.0 OpenSSL/1.1.1g (Schannel) zlib/1.2.11 brotli/1.0.7 libidn2/2.3.0 libpsl/0.21.0 (+libidn2/2.3.0) libssh2/1.9.0 nghttp2/1.41.0

Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Aug 21 2020 11:01:41
wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.73.0
OCE: 6.9.1
Curl: 7.71.0
ngspice: 32
Compiler: GCC 10.2.0 with C++ ABI 1014

Build settings:
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=OFF
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_SPICE=ON

No responses. I guess I am the only one crazy enough to try putting a zone on the Dwgs.user layer.

Hmm, this might be a bug, I didn’t know we allowed placement of zones on non-copper layers

Thanks. I don’t know if it is important enough to call it a bug? I am not sure:

When I place a zone on Dwgs.User, do others react “Why would anyone want to do that?”

My answer is that I am trying to create documentation, pointing out circuit areas. A zone sounded like something to try but I could try circles or (sort of) a shape made of graphic lines on this layer.

Using lines and circles on Dwgs.User would be the natural thing to do for me, but I wouldn’t call it crazy to put zones there.

Thank you for voting for my sanity… :slight_smile:

Actually, this behavior seems to be common to all zones that are not on copper layers. A zone on the solder mask layer (which acts as a “no soldermask” area in this case) is also obscured by other objects even if this layer is selected.

Thanks for the comment. Does a zone on the solder mask layer disappear when the visibility of the solder mask layer is turned off? The zone on Dwgs.User stays visible even though layer visibility is turned off.

We do apparently - the dialog is for “non copper zones.” They actually allow you to have hatched filling as well (so slightly more powerful than a filled graphic polygon.

This is definitely a bug - please report it over on the issue tracker so it doesn’t get lost. The zone should be hidden with the rest of the items on the layer.

I don’t quite understand what you mean by this. Can you provide some screenshots?

I think this bug is probably about zone virtual layers; they aren’t handled right for non-copper zones

Please see the attached .gif.

The Dwgs.user layer has 2 zones and a circle. Layer color is (Purple or pink? I am not sure what to call it because I do not buy lipstick).

You can see that with both top copper and Dwgs.user layers turned on, the Dwgs.user zone is obscured by top copper regardless of the active layer chosen. The circle on Dwgs.user is fully visible when Dwgs.user is active layer. Also the visibility of the zone in Dwgs.user does not toggle with layer visibility.

I have reported the bug: https://gitlab.com/kicad/code/kicad/-/issues/5704