[nightly build] Libedit save as crash bug? (SOLVED)


#1

Coul someone confim me this:

  • run the Kicad launcher,
  • click a library editor icon,
  • select menu File \ Save Current Libraty As…
  • here I get GPF.
    Anyone else?

Application: kicad
Version: (2017-04-02 revision 2c33fad45)-makepkg, release build
Libraries: wxWidgets 3.0.2
libcurl/7.52.1 OpenSSL/1.0.2k zlib/1.2.11 libssh2/1.8.0 nghttp2/1.19.0 librtmp/2.3
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW

  • Build Info -
    wxWidgets: 3.0.2 (wchar_t,wx containers,compatible with 2.8)
    Boost: 1.60.0
    Curl: 7.52.1
    KiCad - Compiler: GCC 6.3.0 with C++ ABI 1010
    Settings: USE_WX_GRAPHICS_CONTEXT=OFF
    USE_WX_OVERLAY=OFF
    KICAD_SCRIPTING=ON
    KICAD_SCRIPTING_MODULES=ON
    KICAD_SCRIPTING_WXPYTHON=ON
    KICAD_SCRIPTING_ACTION_MENU=OFF
    BUILD_GITHUB_PLUGIN=ON
    KICAD_USE_OCE=ON

#2

Generally any GPF should not happen, so it is worth investigating.

The following is a standard answer, since it occurs so frequently

What are KiCad nightly builds?

Nightly builds are not releases, they are test builds. If you use them, you should expect to encounter problems. If you find a reproducible bug that is not already known, please raise it on the bug tracker and provide sufficient detail to investigate the problem. You are not obliged to do this, but it will help improve KiCad for everyone.

Monitor the following sources of information in order to find information about recent changes and known issues:

Recent changes https://git.launchpad.net/kicad/log/?h=master
Recent bug reports https://bugs.launchpad.net/kicad/+bugs?orderby=-id&start=0
Developer discussion https://lists.launchpad.net/kicad-developers/date.html

Unless you absolutely need a feature only found in a nightly build, or wish to participate in advanced testing, you should use a stable release. If you publish projects or footprints created using KiCad, you should use a stable release version as otherwise the project may be unusable by people using the latest stable release.


#3

I was able to replicate this, so I have raised it.
https://bugs.launchpad.net/kicad/+bug/1678698

It is not a valid thing to do as there is no library selected or symbol to save, but crashes should not happen.


#4

Fixed immediately, that was fast :sunglasses:
https://git.launchpad.net/kicad/patch/?id=1f3fe6fefb77fdbcd80ee673e0167d3ff3585942


#5

Cool, thanks for helping to improve KiCad :thumbsup:

Crashes do seem to get swift attention.


#6

Latest Windows nightly 4/4/2017 now has the invalid “save as” disabled, preventing the crash