Newly created footprint library does not appear in list of available libraries

I’m pretty sure I’m just missing an obvious step, but I can’t get newly created or imported footprint libraries to appear in the list of available libraries in the footprint editor. Below shows my Vibration_Tolerant_Caps library in the Manage Footprint Libraries window, and then the libraries available within the footprint editor. Any ideas on where I’m going wrong?

[edit] turns out new users can only post a single image in a post, so you’ll have to just trust me that the list ends like:

  • Transistor_Power_Module
  • Valve
  • Varistor

without Vibration_Tolerant_Caps in it

Version 7.0.1, release build
wxWidgets 3.2.2 Unicode and Boost 1.80.0
Windows 10 (build 19044) 64-bit edition

Hello and welcome @mrWiz

This FAQ is a good read. Symbol and Footprint Libraries are treated exactly the same way.

Thanks for the response! When I follow those instructions (adjusting slightly for a footprint library instead of symbol) everything goes well until this step:

The new Footprint Library does not appear in the list of libraries in the Footprint Editor.

Did you create a folder/folders with your OS somewhere on your computer before trying to create a library and did you also make sure the full path to that library you are trying to create is showing in the green rectangle of the first diagram of the FAQ?

Also, you need to read another eight forum posts to self promote yourself to Forum Level - Basic after which you may post many images (see FAQ “New Member Information”).

Thanks for helping me figure this out, jmk! The base folder I’m using in this demonstration was created by KiCad during its install procedure, and then the .pretty folder is created during the New Library step I’m now completing. I’ve also attempted this from a different base folder not created by KiCad, with the same results. In all cases, the folder does actually exist, and the .pretty is created by KiCad during the New Library process. Here’s a detailed account of my workflow:

  • Go to File->New Library
  • Select Global in the dialog box and click OK
  • KiCad opens a file/folder creation dialog in its default footprint directory. I replace the default Library.pretty filename with something more creative, like test3.pretty and click Save
  • I check the libraries in the list to the left, and test3 is nowhere to be found
  • I check the libraries listed in Preferences->Manage Footprint Libraries and find that test3 is present and marked as “active”

Inside this green box should be the full path to your library.

First, close Kicad, THEN: using Windows, not Kicad,
Go to documents folder then create a “kicad libraries” folder (for Symbol, footprint &3D) then you need to create individual folders, one each for Symbol libraries, footprint libraries, and 3D libraries inside the “Kicad libraries” folder.
THEN, open Kicad, go to Footprint Editor then File > New library > Global > Then use the list on the LHS to navigate to your folder.

So, your path inside the green box should look like:
C > Documents > My_Kicad_libraries > Footprint libraries

When the path is correct, name your library, then save.

1 Like

Yes, that was it! In addition, once I created test4.pretty using that method, all the missing libraries I had tried to create / add previously appeared as well.

Thanks for your help!


1 Like

Exactly where was the problem? Did you find the FAQ guide confusing, and if so where?

I’m interested to know so I may improve the FAQ… I’m looking for feedback. :slightly_smiling_face:

The library management guide below the library creation is useful for positioning your personal libraries in the library list.

I was surprised that there is a distinction between this:

and this:

The location in the second image (which did not work) was the default save location that the file dialog box presented to me, and the location where KiCad chose to put all its library directories. It seems like it should default to a path representation that it can recognize.

Thanks again for helping me get to the bottom of this and for your work with the FAQ! Both are much appreciated.

Also, having a library associated with the second path representation prevented other libraries from being displayed in the list, until I associated one in C:\Users\mrWiz\Documents\KiCad\7.0\footprints\. After I did that then all the libraries I tried to add (including a couple in regular-old paths like C:\offline\kicad all suddenly appeared.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.