Newbie Snap to Grid Zoom

I was getting frustrated because it appeared that my cursor was not snapping to the grid. Searching a few times I did not find the answer. I was trying to draw on the Edge.Cuts layer to define the size of the board.

Here is the answer.
I had my grid spacing set on 0.127 mm while I was zoomed out at board level of 33mm x 40mm. The cursor was snapping to the grid but I needed to zoom in to be able to see it. I changed the grid spacing to 1.27 mm.

Now I’m realizing even though my project is set to mm the first grid setting selections are millimeter representations of inches. Why hasn’t everything changed to Metric only yet? Life would be a little more relaxing.

Don’t blame KiCad.


And the metric board has been abolished in 1982

But there still is the "US Metric Association: which has been trying to accomplish something since 1916.

And even here in Europe car fanatics hold on desperately to units based on some four legged animal and housewives trying to loose weight are counting calories, for some completely mysterious reason omitting a “k” prefix, which prevents them from loosing weight real fast, and when you try to explain to them what a Joule is they stare at you incomprehensibly.

1 Like

Look at the full list of grid settings in the drop down. Scroll down. I think you really want metric, not fractional inches.

In eeschema, never change the grid.
In PCBnew,
I use 5mm for edge cuts.
1mm for component placement
0.1mm for traces.

The N key changes the grid.

Since you’ve obviously got a pcb going, don’t change the grid to metric.

This is no more:

I don’t know exactly when it changed, but in KiCad V5.1.10 it only shows one “main” unit, and the other is shown in between parenthesis. Switching is done with the in and mm icons in the toolbar on the left:


For designing PCB’s I mostly use metric, except for THT footprints which I place on a 2.54mm grid for breadboard compatibility.

And indeed. switch between grid sizes. Using a coarse grid to draw the PCB outline, mounting holes and such helps a lot with aligning them in rectangles.

iabarry is also right about warning about the grid in Eeschema. Eeschema relies on perfect coordinates for accepting connections between wires and pins of schematic symbols. and this can only be done on a coarse grid. If the connection is correct, then the circle from the pin disappears, and the square at the wire end also disappears.

This is a good connection:

This pin is not connected to the wire:

And when you run Eeschema / Inspect / Electrical Rules Checker then it also tells you so with Pin not connected errors.

This is also why I like the No Connect flag so much. If you forget to make some connection, then ERC alerts you to that fact.


I have all lines at CrtYd in 0.1mm greed and place all elements in 0.1mm greed in most cases with CrtYd rectangles touching each other.
Before KiCad I had those all in 5 mils greed.

I’m so used to the keyboard shortcuts that I didn’t realize the drop down was changed.
Thanks for pointing this out.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.