Newbie - Eeschema has no standard libraries?

New user here, but used several other schematic capture programs before. When I first opened Eeschema, there was a one-time message about libraries that I didn’t save (what did it say?). Now I see there is only a power library and I have no idea how to get started. The “Getting Started in KiCad” document apparently assumes more libraries are installed since the first step is to choose a component from the library. My library browser showed only “power”. I used the “component libraries” in preferences to select several libraries, but I still can’t find any standard components such as resistors and caps. What am I missing?

Hey marko, what platform are you on (Linux, Windows, OSX)? Are you using the latest stable release (4.0.5)? Are you saying you only see the “power” library in this dialog?

I’m using 4.0.5 on Windows 10 (64-bit). Yes - only the power library appeared in the dialog. I have added other libraries, but still no resistors or caps. All libraries appear to be application or vendor specific. I would expect to see some “standard” library.


If your dialog looks similar to my screenshot above then you have the standard library. It has some weird categories for sure but don’t let that confuse you. You could “filter” for resistor for instance and you should be able to place that.

I added the “device” library and now I can place resistors. Thanks for the help. I don’t understand why this library isn’t installed by default and no reference in “Getting started in KiCad”. :slight_smile:

Im also new (installed KiCad 4.0.5 on W10 yesterday) but for me it was installed by default.

The device library is normally installed. I think that you have a problem with your library paths

What do you have in Eeschema - Preferences - Component Libraries - Current search path list?

Depends on the operating system. Some linux distros have the libraries as seperate package.
The windows installer has the option to not install the libraries.
This feature is added to enable the user to update kicad without changing his libraries.

Better solved by saving any modified standard library parts with new names in your own libraries. Even if you freeze modified standard libraries, you face trouble when you copy the project to another PC

In this search path, there is:
C:\Program Files\KiCad\share\kicad\library
C:\Program Files\KiCad\share\kicad\template

The pre-selected component library files only included “power”.

Are there files in [C:\Program Files\KiCad\share\kicad\library]?
(There should be a lot of .lib and .dcm files there.)

If these files are there, you can add them in the same dialog.
just use the upper add button.
In the pop-up that opens go to this directory and select all these files.
Press ok and restart kicad just in case.

If these files are not there, try to re-install kicad. (i never installed it on windows but i’m sure the windows installer has some way to select if you want to install the libraries.)

Yes - the files are there. I did install the “devices” library and now I have resistors and capacitors available. I think it’s all working correctly now. It’s just weird that only the “power” library was available after installation. I do remember seeing a one-time notification (something about libraries) when I first started KiCad, However in my haste to get started, I clicked through it and never saw it again.

Just a heads up on that one and as you seem to be on Windows.
If you ever customize your KiCAD install don’t forget to disable the environment variables before overwriting the ones you got…

1 Like

A post was split to a new topic: [OS X] Eeschema loses standard libraries?

Just had the same problem after installing 4.07 under Windows 10 64bit

I’m guessing that it might be related to the fact that I chose a non-default installation drive/folder? (i.e. e:\KiCad) - I can see a load of library files in e:\KiCad\share\kicad\library and if I add them individually to the component library files dialog window they appear to work.

Kicad 4.0.x doesn’t “install” all the available libraries into new projects by default. The default set is defined by the project template file “” (C:\Program Files\KiCad\share\kicad\template)

KiCad v5 is completely different and uses a global a symbol library table.

1 Like