New to this. CVPCB doesn't have any footprints. Help!


When I watch tutorials, There are complete libraries of footprints when CvPCB is being used. I have none and don’t have any understanding of the program to try to make things right. Would someone mind helping me figure this out? Thanks!


to even begin to help, Version # and OS, start with that. because … i have twelve different responses… EDIT i am not trying to be mean… I simply do not know where to start.


Have a look at this FAQ post: (press the link or somewhere near the top right corner of the gray area to read the full thing.)


Thanks! It’s 4.0.7 on OSX (10.13.3). You didn’t come across as mean at all. I really appreciate the help!


Thans! Looking at that page, the first option (cvpcb) shows an entirely populated left column. On mine I have one item; nothing more. I am struggling figuring out how to properly populate it. Thanks!


It sounds to me that you don’t have your footprint library table populated. Check out this section of the official documentation:

This section also applies to Pcbnew. Once you have your global footprint library table populated, it should be valid for all projects that you open. The local library table (one of the two tabs in the library table dialog box) is project specific and CvPcb and Pcbnew will both use it.


In addition to the link provided by @SembazuruCDE you can also look at this FAQ article: How can i install a specific version of the footprint library?


in cvpcb/Preferences/Configure Paths what do you have listed ??
since your watching tutorials… lets start from scratch. ok? we make a new project … first thing we do. check your PATHS. > Preferences/Configure Paths we want to see… that your list is populated. it “should” look like the picture that was posted by@sembazurucde here>

we do NOT want to see a list with $KIGITHUB listed as the location of files.
we DO want to see a the contents of this file “renamed” as… fp-lib-table

its important that both files be in your kicad user directory/folder.
doing that… you should be a happy camper…


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.