New to the latest Kicad and trying to re-learn


#1

Hi,
I’ve been using Kicad for a while now, but recently it changed and now uses such words as PRETTY, etc.
I am now trying to re-learn the new system, and it’s not so easy.

Anyway, I tried to download the latest files here:

but it didn’t work! Is this something that has happened before?
Cheers, Camerart.


#2

Big green button and Download ZIP. But you will get only recent project templates, schematic symbols and 3D models. For Pretty footprints go to Pcbnew and start Footprint Libraries Wizard http://docs.kicad-pcb.org/stable/en/cvpcb.html#_using_the_footprint_library_table_wizard


#3

Since 2015 (or better since the 4.0.0 release)


#4

Hi,
I’ve clicked the big green button a few times today. Now I’m not sure what to do, but perhaps all will be clear tomorrow.

So far I haven’t found any reference to Voltage regulators, are they supported?
C.


#5

Yeah regulators are supported in that you connect to them via pins and can associate them with a footprint. Sounds like this person went through something similar to what you’re running into:


#6

Of course voltage regulators are supported. There is a library called regul.lib in that list, and it has a bunch of voltage regulators in it. Of course, the regulator you might wish to use may not be in the library, in which case this is the opportunity for you to learn how to make your own library parts.


#7

Well, that is NOT the easy way to add libraries…

Keep in mind, that Eeschema and PcbNew use different techniques.

Since you mentioned “.pretty”, I am going to assume you are trying to download FOOTPRINT libraries.

In PcbNew, select the “Preferences” dropdown menu then select “Add Footprint Libraries Wizard”.

Select “Github repository” and click next.

The rest you should be able to figure out.


#8

If you want to use them offline or without network load make a tick at the ‘store locally’ option there.


#9

Hi,
In one of my previous questions, I asked about footprints for Regulators. In this case, I have the .LIB REG file, but not the FOOTPRINT.
Here is the GITHUB download screen, and I still haven’t found any reference to any REGULATOR.

Also earlier, I was faced with a POPUP stating that files can not be saved in a particular folder, and the answer was to find a folder that the user has ADMINISTRATION rights. I found that if KICAD was opened by right clicking the mouse and choosing ADMINISTRATOR, I was allowed to save in the default folder.

As mentioned I download files elseware, and want to save them and use them OFFLINE.
C.


#10

You need search by real package type. If you have L78S05CV (ST part) in TO-220 3pin package look for TO-220 which is in TO_SOT_Packages_THT.pretty footprint library; not for 78S05 or regul.
Keep in mind that many footprints are used for wide spectrum of components on the market.

Sorry. KiCad does not support full Windows UAC and Virtual Store weirdness. I advice to install KiCad outside the Program Files.


#11

Hi K,
I tried un/reinstalling it in it’s own folder outside ‘program files’ but I still can’t save what I have download. I have Windows10, and have the Windows Kicad.
C.


#12

Do you only have one partition on your machine or can you create another one in the remaining free space by reducing the one you got now?

You then can keep the libraries in that partition and other data as well.
That’s how I have it (E: contains all my data - easy to backup then as well).

KiCAD:

C:\Program Files\KiCad

Libraries + Projects:

E:\Data_KiCAD


#13

Hi All,
SUCCESS!
I have uninstalled and re-installed Kicad 4 or 5 times now, trying to always do a fresh start. I tried installing it in the Program files, but couldn’t get the ‘combination’ for success.

This time I installed it in a folder on the desktop (I tend do do most things on it) I right clicked the Kicad link, opened with Administrator, which allows saving downloaded files. In PCB and footprint libraries manager, and deleted all of the libraries, then downloaded new ones from Github, and all appears to be working.

Thanks for all of your patience. Camerart.