New symbols from old


#1

Hi I have now switched to the nightly builds . I think version 5 will be realy good, but i have run in to a problem, in that any librarys i created myself no longer work . They seem to contain no components. Is there a script to change from the old format to the new? or can you detail the changes needed in the lib file ?


#2

That’s strange. The old format is supported by Nightlies. So you should be able to use them. (the other way is problematic.)
Could you share one of your libs?


#3

ok MyLib.dcm (6.7 KB)
MyLib.lib (97.9 KB)


#4

I can open the lib normally in my nightly. (Ubuntu from a few days ago) Tested looking at the symbols via the symbol editor and added one of the contained symbols into a schematic.

How do you try to “open” the lib. (So give more details what you try do to and how you tried to achieve it.)

Also the lib is already saved as file format version 2.4 which was introduced to nightlies shortly before the feature freeze. (This means version 4.0.x will not see the content of the dcm file.)


#5

Thanks for the help . I opened the library in the library browser. but it showed no containing components, but i did open a seprate project and it came up showing the library components in the browser . i may have a corrupted project folder . The project i’m having problems with i formed by apending a sheet from another project. I will investigate more. again thanks for your help.


#6

Is the lib added to either the project local or kicad global sym-lib-table? (Check via the library manager found in eeschema -> preferences menu. It might have moved to the setup menu.)


#7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.