New project template problems

Hello, I have just created a new project template on Windows. Unfortunately, not all file names and paths are customized when creating a new project.
template.7z (247.1 KB)

Error loading schematic line 1, offset 1. “C:\Users\Lutz_Müller\Documents\Kicad\Projekte\TestElektro\TestElektro.kicad_sch”.

Now I’m trying to open the symbol library and I’m getting this error.
Errors loading symbols:
Error loading symbol library 1.
Library file ‘C:\Users\Lutz Müller\Documents\Kicad\Projekte\TestElektro\Elektrotechniker.kicad_sym’ not found.
Error loading symbol library Elektrotechnik.
Library file ‘C:\Users\Lutz Müller\Documents\Kicad\Projekte\TestElektro\Elektrotechnik.kicad_sym’ not found.
The created folder will then look like this.

I’m a bit at a loss.

So, I’ve now gotten to the bottom of the errors.

  1. Error: The created file with the ending “*.kicad_sch” cannot be read.
  2. Error: There is an incorrect link to the file in the “sym-lib-table” file. Or rather, the file with the ending “*.kicad_sym” should not be renamed. I believe this is the simplest solution.

I tried to open the schematic file directly with the schematic editor and it also gives an error.

Good morning everyone.
I have now carried out extensive tests and have come to the conclusion that the symbol files cannot be renamed. Then they will also be loaded.
Regarding the second error, I have to say that the error can be found in the file itself. After I recreated it, it worked.
Elektrotechnik.7z (244.8 KB)

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.