New library format

A bit embarrassed to say that even though I have a more recent build of KiCad on Linux (on a VM on my mac), I really haven’t created anything from scratch on that build yet. I continue to build stuff on my stable Windows machine BZR4022. I keep getting these errors when opening a file:

I’m pretty sure this is due to the default libraries changing extensions in the newer versions, but am not sure. Also thought I would share my pain as I am likely not the only one doing it.

Interesting sidenote: the reason I have been OK with other designs I have opened in BZR5xxx so far (even though they were made in BZR4xxx) is because the KiCad file format stores footprints/symbols in the library cache files.

Hi Chris

I have to say, I feel your pain!
I’ve gone through the same on my main work machine when KiCAD switched over to these .pretty GitHub repositories.

Seriously, why does a library need to be online without some sort of offline synchronization mechanism? I feel the developers have taken a turn for the worse with this decision if you’re thinking about semi-professional pcbs.

The searching of the library is slow, you can’t work offline and even though I support a large ‘starting’ library of the most common footprints stuff like a SOD123 are not yet included in these default libraries.

To fix the missing libraries I now have to set the following variable in my Windows cmd prompt: SET KIGITHUB=
You’ll have to the do likewise on Linux by adding a shell variable and then starting kicad from the command prompt.

This way all these libraries with the following format ${KIGITHUB}/Housings_SOT.pretty will be found.

I believe the easiest way around these online libraries is making a clone of the repo on your local drive and then point the KIGITHUB variable to that particular folder.

Much hassle if you’re running kicad for the first time…


Those are the schematic libraries that it is complaining about. They’ve not changed format/location in years so it’s nothing to do with the new library format.

How did you install, did you use the script? That’s meant to install the libraries in the default location.

I’ve noticed some issues moving from Windows to Linux as some paths seem to get hard coded on Windows so maybe it’s looking for the libraries in the wrong place. If you open a schematic and dismiss the warnings then click Preferences->Set Active Libraries have a look in there at where it’s searching for them. Default location on Linux if you use the script is /usr/local/share/kicad/library