New install of 5.1.6 - CvPCB does not work

Very recently I uninstalled KiCad v4.0.6 which I had previously successfully used to create 5 PCBs.
I uninstalled this old version (after advice to upgrade) and installed v5.1.61. I am now creating my first PCB with the new version. The immediate problem is that CvPCB does not work, that is it does not filter by pin count. It makes the tool a PITA to use. I have successfully used this tool in V4.0.6 and I have tried different settings of the buttons. Library part filter by pin count is broken for me.

Now what is strange, is that a friend also upgraded to the same version, but from an earlier version v5. Showing me his screen I could see that CvPCB was working/filtering as expected.

Any ideas what I need to do to get my install to work?

Well you need to activate the filter in the top toolbar. See How can i assign a footprint to a symbol?

1 Like

Hi @rene_Poschi,

“Well you need to activate the filter in the top toolbar.” - I am very well aware of this (and I did mention it in my posting) as I used this feature in v4. Regardless of the setting of the filter, the filter by pin count did not work. The rightmost box was empty (apart for a single library which did filter by pin count - bizzare!).

Thanks to a friend who suggested this. I did two things. I cleaned out my “TEMP” area (Win10). I also deleted the folder c:\users\me\AppData\Roaming\kicad. I then created an empty folder. I re-started KiCad and the problem has disappeared. [Note: this was a new project in v5] I had to change the old associations which I had managed to find while the tool was broken, but now that filtering is working - this was very quick. I have spent tonight laying out a new board.

I hope this helps anyone else who might find themselves in the same position!

2 Likes

If you state a filter does not work one would assume the result list contains stuff with more or less pins. If the result list is “empty” or has “too few” elements then the filter is most likely not the thing that “does not work”. And all of that could have been mitigated by just adding a single screenshot.

I am thankful that the OP stated that the filter does not work because I experienced the same problem after I upgrading from V4 and searched for “cvpcb pin count filter not working”. Fortunately I found this post. I just cleaned out the roaming\kicad directory and now the filter works.

2 Likes

Wow! great to hear that in solving my own problem I helped someone else :slight_smile:

1 Like