New install but I've a problem

Hi, I’me new for this cad system; I’ve install version 5.1.5_3 on S.O. Windows 7 but not run: Eeschema may be on loop, and icon mouse not respond on click. May be a problem on video card (Intel® - Express Chipset G41 (Microsoft Corporation - WDDM 1.1)
thancs for reply.

Eeschema in the 5.1.x does not make use of accelerated video, so should not have high requirements on graphics hardware. What do you mean “may be in a loop”? What happens with the screen - does it dim as system-level unresponsive application, or just does not register mouse clicks?

I’m not sure if you can run Eeschema if no project opened.

@mauste Please make sure you have the latest intel video driver for your system. I have no idea about the video card, but please ensure you have a recent driver or try to downgrade if your are already up to date. But you should also be able to run in the fallback graphics mode instead.

Maybe you need to do this manually by opening the file

%APPDATA%/kicad/eeschema

and change canvas_type or add as follows:

canvas_type=2

1 Like

Thank you for reply nickoe, I think… a problem are on video card because a message appair only on pcb and gerber applications: my card not support acceleration hardware and not use opengl library. The Intel G41 not support this but only Eeschema not run, other applications yes. Ok I install a new card and… OK thanks

It does, you can choose between Accelerated and Fallback. That’s why @nickoe’s advice to change canvas_type in the config files (eeschema, pcbnew, gerbview) manually with a text editor could work. @mauste, you should try it.

There have been other problems with opening different parts of KiCad which cause KiCad to hang, it’s not necessarily the graphics.

1 Like

You’re right I can see the acceleration options in Preferences.
I was under the impression that rework of the display canvas for EESCHEMA was targeted for 6.0.
So. My fault.

This “canvas_type” thing has been mentioned a lot lately.
https://forum.kicad.info/search?q=canvas_type%20order%3Alatest

Should go into general “Preferences” panel for the Launcher, so OpenGL could be disabled before running apps that use OpenGL. Otherwise, users with driver problems are forced to manually edit configuration files.

That’s true. I would also suggest having a Graphics Rendering Test tool which could be launched from the project view. It would actually test rendering, not just see if OpenGL is available. And it would do it by instantiating both eeschema and pcbnew canvases, so that it would test it for real. In that way this canvas rendering problem could be separated from other possible problems, and we could ask the user in need to run that tool and tell us what happens.

No need to move preferences or add special tool. There is just a bug in how detection of opengl capabilities works, eeschema should not freeze but simply fallback to cairo canvas automatically.

I think I read somewhere that this was already fixed in pre 5.1.6 but can’t be bothered to find any confirmation.