Net Highlighting with limited selectability

I remember a function, that was available in version 5, where the shown icon is located.
Bildschirmfoto vom 2022-05-09 19-49-28
With activated icon I could select any copper line in the layout and the whole net was highlighted.

This is something I’m missing in version 6.0.5 (and before).

I checked the documentation for net highlighting and found out, that the context menu is available and operating properly. The key shortcut isn’t working well, I have to redefine the selecting key to make this feature working, the default key " `" and " ~ " isn’t working. (maybe because of german version/localization/keyboard?)

As already said, nothing is happening when selecting the icon or with selected icon.

For curiosity, what are the context menu entries “hide net” and “show net” for? I see no effect in the layout.

It would be nice to get the icon operating again.

You can also use ctrl+click to net highlight.

Unfortunately various keyboard layouts have issues with some shortcuts; this seems to be a currently unsolved problem: Kicad5.99-> some HotKeys not allowed on international keyboards (#6645) · Issues · KiCad / KiCad Source Code / kicad · GitLab and others.

The hide/show net feature is for hiding/showing ratsnest lines. You won’t see a difference if your board is fully routed.

Does it work if you select a track segment, tnen right click and select Net Tools / Highlight Net

It’s not very convenient to do this a lot, but it should bypass keyboard and locale issues.

Dear gkeeth,

thank you for the hint, I didn’t noticed this in the documentation. And yes, it works. The only drawback is the deactivating of the highlighting. A normal click without ctlr doesn’t help. Any furhter feature available I do not know?

Dear paulvdh,

this is what I wrote about contect menu (selection and right click): it works. But in the final stage of the layout, in the review of the board, a little bit inconvenient.

Oops, my bad, did not read it carefully enough. Sorry for that.

When checking a lot of nets, clicking on icons is a bore.
But there is an alternative. On the right side of the screen there is PCB Editor / Appearance Manager / Nets and this has an icon for the Net Inspector With this you can cycle through highlighted nets with just the up and down arrow keys.

You can even highlight multiple nets at the same time by shift clicking and using the filters.

It’s also available via Pcb Editor / Inspect / Net Inspector

3 Likes

You can ctrl+click again in empty space to disable highlighting.

Thank you for the hints, I will try them.

@gkeeth: This didn’t seem to work since I have no empty space on my PCB. Doing this outside the PCB is deselecting the highlighting mode.