Need GND Trace even After GND Zone Fill?


#1

I added a top and bottom GND fill and have refilled my zones, but I noticed some grounds still want to be connected to other grounds with a trace. When I added a trace I noticed that adding this trace makes a different ground want to be connected with a trace. I assume I’m breaking my filled planes up to much or something?

Some grounds want to be connected even with a GND fill on the top and botton laers (2 sided board):
Kicad_3

I added a trace and now the bottom left GND pad want to be connected to another GND
Kicad_2

Here’s what my fill zone looks like:
Kicad_1


#2

If you look at the two resistor/capacitor pads on the right side, they are not connected anywhere (just a dangling tiny GND plane), so KiCad shows a missing connection. Same about the GND pad of the chip to the left, there’s not enough space to fill anything around pad no. 4. The easiest solution to fix this would be to place vias to connect these pads to the GND fill on the bottom layer.

Cheers,
Tom

PS the annular ring (width of the copper rings surrounding via holes) of the vias on your PCB looks very narrow, the PCB fab will likely complain about it.


#3

To pile onto what @twl wrote…
Just because you create a filled zone and set it to GND, doesn’t make this GND net to reach all the places it needs, for it to connect all the devices that need this GND connection.
You have to take care of that.
And KiCAD helps you by showing with the tracers which GND islands are not connected to the net GND yet.
If you have GND zones at top and bottom, connect them both in as many places with vias, so that the current flow has many shortcuts for all the devices to make it to back to ground.

example (was a former KiCAD version, where we couldn’t place ‘free’ vias like in v5, so you can see the track’s that I put in for that purpose):

One could make the following changes to your layout in that area - just to get you rolling on the idea how this works (I usually make one via per pad if it needs to connect to a plane on another layer, if space for it is there):

image


#4

Yes, as above, you still need physical pathways to connect to all the GNDs following the design rules.
In tight areas, I usually run specific GND routes, as that guarantees there are connections.
Routes often have slightly tighter rules than fill-fingers.

but you can connect by rule, if you are careful in your constructs and later editing.
eg your top-right hand via, can move left to allow a fill channel pathway to the 2.GND’s
The 4.GND might get enough room, if the angle part of RX2_micro trace pushes right.
If still not enough, drop the 2 passives until there is room, etc… you get the idea.


#5

Thanks all for the replies, that makes sense! I really appreciate the help.

I have one more connection question for the moment. On a couple parts I have lines going to/from places and I’m not sure what they mean or what to do to get rid of them (see pictures). The ground connect I think I understand from the explanations above, but the other on R33 I don’t understand:

kicad_6

Kicad_7


#6

Doesn’t look like a prob with R33 or any device in that area… might be the front and back filled zones there having troubles?
Are they filled if you switch the viewport to filled zones instead of outline/hatched?

Or run DRC with all options and see what it tells you on the ‘unconnected items’ tab?