Need a little help: missig 3d-model in Pcbnew


iam a little confused. I have my own 3 model copied into the default directory for 3dmodels.

I can see the model in the 3D-Preview in the Foorprint Editor but in Pcbnew the model is missing.

Dig i forget something?

thx Zh4ng

Try updating the footprint :slight_smile:

@Shack it did not work. In PCBnew the model is still missing. In the footprint viewer is the model visible…

In 3D viewer you can enable/disable SMD TH and Virtual through the menu

Other 3D models are ok. Only my own footprints don’t show the models. I tried to add an default model to a other footprint in my library. doesn’t work ether.

something i do wrong :frowning:

Do you see your model in footprint editor inside the board or from the footprint standalone? Sometimes the footprint in the board is not aligned to the footprint in library

@maui i think it’s ok…

Can you show us the footprint properties dialog of the placed footprint? (press e while your mouse is over the placed footprint in pcb new)
Especially the 3d shapes tab would be interesting.
(Maybe also show the same tab from within the footprint editor.)

sure :slight_smile:

Is this screenshot from within pcb_new or from within the footprint editor?
Compare the 3d shape names entry and also all values in 3d scale and position between this two possibilities. (maybe there is a difference.)

Also what is your kicad version?

Ok, intresting. The frist screenshot is out of the footprint editor.

This one out of pcbnew. No model definde. hm, but why? I add the model later to the footprint. Is that the problem?

As ex-eagle user i did not understand the workflow of kicad completely yet. :confused:

Iam using KICAD 4.0.5

for that reason I posted

the footprint inside the board is not automatically aligned to your footprint library…
this is a plus, because your board has everything inside

1 Like

In kicad footprints are not updated automatically if they change in the library. you need to trigger this update. (In eagle there was a update from library menu entry that did the same thing if i remember correctly)

open the footprint properties in pcb_new (press e while mouse is above footprint)
Select change footprint.

In the window that opens:
under options choose appropriately (Either change footprint of “this reference” or change footprints “footprint name” the later will update all footprints with the same name.)
Don’t change anything else and press apply.

I’m not sure if this will update your footprint if only the 3d models entries have changed. (If it is not updated, simply enter the stuff manually. It is not that much stuff to enter for just one footprint.)


Thx man,

“Change Footprint” -> under Options -> “Update all footprints of the board” thats it !!!

As i said , as Eagle User it is a little bit wired. But the change from eagle to KiCad seems not so heavy as i was think before. It was the first time i really have struggled with KiCad.

@maui Now i understand the way how KiCad manage the components inside.
Thank you too.