My 'Footprint Editor' doesn't look like anyone else's? [Solved]

Hey all,

I am getting to know KiCad for the first time, and I’m having a problem trying to get the Footprint Editor to work. Every video I watch, the person opens up the editor and a black screen is there where they can place holes, etc.

But on my computer, its just a grey screen, with no way of adding anything to the footprint. I can’t find any way of changing it, and have been fiddling with the .lib and active library files a whole bunch.

Any ideas why there’s no editing screen? Thanks!


Of course after 2 hours of ****ing around with this thing, I post this and figure it out 2 minutes later lol. I guess that’s how it goes. Anways, if anyone cares, (or even wants to explain why this fixed it…):

Selected: Preferences > Modern Toolset (Accelerated), originally was Modern Toolset (Fallback)

I don’t know what that does or why it fixed it, I had not ever clicked it before.

You could have hit the wrong F(X) key?

1 Like

The original behavior sounds like a bug. Would you care to report it? (The fallback mode should always work. Accelerated is the one that relies on hardwar/driver support.)

Judging by the looks you have some older version of KiCad. Try 5.1.2 (or soon 5.1.3) if possible.


I believe this must have been the issue. I may have accidentally hit an F11 or F12 key much earlier in the day, and it didn’t cause any issues until much later. Thanks for the help everyone!

The fallback mode should still not behave that way. So please report the issue over at launchpad.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.