My 3D model orientation is not correct?

Hello guys,

I’ve added my connector model to the KiCad. The symbol and footprint as far as I understood look right. However, the orientation of the 3D model doesn’t look right It’s supposed to be horizontal. However, It’s vertical. and comes out of the other side of the PCB.

Appreciate your guidance,

The position of the 3d model in kicad is relative to the footprint, also related to the origin and direction of the model itself, if the position is not displayed correctly after import, you can manually adjust the parameters to make it display correctly

On the left you have various settings, like scale, rotation and offset.
You rotation for that and then tweak it with offset if required.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.