Multiple symbols have identical reference IDs of 'Ref**'

i just download some schematics for a mechanical keyboard and i ajusted some switches with the library that comes with the article, but i got this error and i tried everything, including deleting the silkscreen

If you downloaded it and it’s public, please give a link. And tell your KiCad version, copy it with Help → About → Copy Version Info button.

1 Like

okay!

where i get
Application: KiCad PCB Editor (64-bit)

Version: (6.0.0), release build

Libraries:
wxWidgets 3.1.5
libcurl/7.78.0-DEV Schannel zlib/1.2.11

Platform: Windows 10 (build 19042), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Dec 24 2021 19:17:02
wxWidgets: 3.1.5 (wchar_t,wx containers)
Boost: 1.76.0
OCC: 7.5.0
Curl: 7.78.0-DEV
ngspice: 35
Compiler: Visual C++ 1929 without C++ ABI

Build settings:
KICAD_USE_OCC=ON
KICAD_SPICE=ON

bc i want to use auto router to finish the edits that i made

Hello, I think you have to re-annotate all components.

1 Like

Actually it’s correctly annotated. The board has footprints for graphics in the silk layer which don’t have a symbol counterpart. They have not been annotated and have “Ref**”. They are not meant for routing but the specctra export doesn’t understand that. The reference designators can be changed manually on the board, or symbols for those footprints can be added to the schematic and annotated.

1 Like

how can i solve that?? bc im new to kicad, im used to use eagle as schematics

Select one of the two “Kobuss” footprints. Open footprint Properties. Change the Reference designator field to some meaningful unique designator which isn’t used in the schematic. As a best practice, check also the “Not in schematic” checkbox. This is by far the easiest way.

The creator of the project hasn’t put the custom footprint library there, so the second way is more difficult and probably not worth it, except for your KiCad training if you want that.

1 Like

so the checkbox needs to be marked?

Yes. It tells the schematic → layout update process that the footprint shouldn’t be deleted along with leftover footprints whose symbols were deleted. When that checkbox is checked, the footprint doesn’t get deleted by accident in the update process.

In the update dialog there’s a checkbox for deleting footprints with no symbols and nothing is deleted by default, but if you want to delete extra footprints, yet keep some, you want to check “Delete footprints with no symbols” in the schematic → pcb update dialog and check the “Not in schematic” checkbox in the footprints you want to keep.

1 Like

it works! one of the drawing that the pcb had was causing the problem! all of the footprints with silkscreen worked fine after changing the reference, thanks a lot! now im routing and finishing the design