Multi-Sheet Schematic Without Hierarchical Sheet Symbols - How Did I Get Here? - SOLVED

I’m no stranger to hierarchical schematics and have used them numerous times using the hierarchical sheet tool. I just opened a project I did some months ago, however, and find that it has a hierarchical structure, i.e. I can pop up the hierarchical navigator and it shows “Root” and the other sheets at a level below, but the schematic contains absolutely no hierarchical sheet symbols anywhere. How did I do this???

I’m not looking for a tutorial on how to use hierarchical sheets “properly”, just how is it possible that I created a multi-sheet schematic without hierarchical sheet symbols? I’m pretty sure I didn’t use File->Append Schematic Sheet Content, because that would have required designing each sheet as a separate project, which I didn’t do.

Using 5.1.6.

Hmmm… That seems odd. Did the top level get del or moved?
Is there a backup or a .bak?

Everything seems to be in order and working fine.

image

The sch files for each of the four sheets are present. “System Controller.sch” is the root, and the other three show up in the navigator:

image

Sys-Control.sch-bak should be the backup file for the top level. Make a copy of the entire dir and try to recover it. That may show the structure.

Mystery solved. The hierarchical symbols were way outside the worksheet frame due to a previous reduction in page size. Either I wasn’t scrolling far enough, or they became “hidden” somehow when the page size was reduced.

1 Like

It would be useful to have a drawing check tool for both schematic and pcb, that warns for anything outside the sheet boundary.

1 Like