Mouser library loader on linux

Does anybody have hints on how to proceed?

A bit more details might be required. What stage are you hung up? What did you already try? What is your end goal? …

I’d like to download ECAD models for KiCAD from Mouser. If I can do that somehow without their Library Loader, please advise on how to do that.

Pressing DOWNLOAD ECAD MODEL for my desired component gives me a zip archive with a readme that tells me to install their Library Loader, and a small file that probably contains a database key.

Library Loader comes as a Microsoft installer (.msi), which I have attempted to install in the wine environment. I guess it ties into the web browser there and installs symbols and footprints and 3D models in the windows-user environment. I did not expect that blindly installing it in the wine environment would achieve anything for my native linux browser+Kicad. And no, it has not.

I have asked Mouser for a linux alternative, but I do not have high hopes.

https://www.mouser.co.uk/electronic-cad-symbols-models/

The Mouser ECAD service is provided by SamacSys, like several other vendors. Not sure whether SamacSys pay Mouser or vice versa. Either way, the data comes from SamacSys and they would like to sell you their service, the Mouser hookup is a “teaser” or advert depending on how you look at it.

Last time I tried to use LibraryLoader, it didn’t work properly even on Windows.

Okay.

Well, it is easy to go to digikey and download the 3d files directly. It would have been nice to have a one-button install of symbol, footprint, and 3D object into a project library within Kicad, though.

<sigh> I guess you just cannot have it all.

1 Like

There is an Eagle plugin, but an equivalent KiCad plugin is currently not possible because the Python API doesn’t have access to the library code (AFAIK).

A standalone part downloader app could work for KiCad, but the user might need to configure the library paths. You might also need to restart KICad to pick up any changes.

So did you try logging into the Mouser tool?After logging in (ooh yes, You do need to sign up before this), I see a window like this:

And when I enter my component in there, I then enter a component name (7404) in this case.

And I can click the image image to see this response:

The free download button for Members now gives me an archive of footprints for a number of ECAd tools. I did not need to download their Library Loader.

Hope that helps…

Regards
Rahul .

1 Like

Just out of curiosity, are any of the file formats supplied in the archive that you downloaded compatible with KiCAD? Either native KiCAD files or file that can be imported into KiCAD? (I think, but haven’t tried, the footprint library manager should be able to load Eagle and GEDA/Pcb libraries. AFAIK the symbol library manager only supports KiCad libraries.)

I use SamacSys ECAD service from Mouser on my Ubuntu 18.04.1 LTS OS running KiCad V5.1.4 (now). When Mouser announced the service and the SamacSys info started appearing on the Mouser parts I downloaded the SamacSys Library Loader but quickly found out it didn’t work. I contacted Mouser and I was told it only worked for Windows. I told them that was nice but they ought to have some sort of announcement to that effect. I contacted SamacSys and they confirmed their system only works with Windows and apparently they have no plans to work on a version to work with Ubuntu (Linux).

Here is the process I go through to get SamacSys ECAD symbols and land patterns (footprints). You first have to sign up on their website with your e-mail address and a password. When I find a Mouser part I go to the SamacSys website, log in, and search using the full Mouser P/N. If SamacSys doesn’t show any ECAD info I submit a request for them to produce it. They say can take up to 48 h but I have received everything I have asked for within 24 h. Be advised that they do not have 3D renditions for everything. When they are done producing the information they will send an e-mail to you. Log onto the SamacSys website and search for the part. Then go to the “MEMBERS” “FREE DOWNLOAD”. It is a zipped file so you will have to unzip it. Go to the KiCad information.

For a symbol there is a multiple step process as follows:

  1. Add the external source *.lib file to the list of Global libraries. (You will have one part per library.)
  2. In the symbol editor open (edit) the symbol.
  3. View the symbol to check it.
  4. Copy the symbol [RMB].
  5. Go to the library you want to save the symbol to.
  6. [RMB] paste the symbol.
  7. Go back to the Global library list where you added the single part library and now delete it.

For a footprint:
Do the same thing as for a symbol except in the footprint Global library and footprint editor.

Hope this helps.
–Larry

1 Like

Or use the import symbol feature of the symbol editor. Saves you one step.
This really only works if there really is only one symbol in such a lib.

Out of curiousity - and maybe for future needs - I registered and tried the web page. It gave a zip file with all kinds of files for different EDA applications. KiCad being one of them. 3D models were step, stl and wrl.

Yep. Models can be imported into KiCAD. 3D models are also available for a few components (Yeah, love pressing that Alt + 3 key combination in PCBNew).

In some places, only KICAD models are available. You can customize after importing.

One word of caution though is that a team-wise process in such library creation is heavily advised. Otherwise, people will end up having different components in the same libraries…

Good to know that registering gives access to the actual models. Perhaps I will get the time to build something from this later. Thanks all for comments.

I’m currently working on a library loader replacement that works on all platforms. (Windows, Mac, Linux).
As of writing this, it parses .epw files and downloads a zipped folder containging library folders for all supported ECAD suites. The goal is to be able to watch a folder for zipped .epw files and output your specified library format to a library path.

Worth noting: You still need an componentsearchengine.com account.

Update:It’s more or less done. It currently only supports eagle, but if you want support for any other format supplied by SamacSys Component Search Engine, just reply to this or open an issue on github.

(KiCad support will be available in a few days)