Mouse wheel sensitivity


It looks like the mouse goes erratic in some cases. I have a PCB open right now in front of me. If I go over the PCB carefully to be sure that the mouse wheel doesn’t spin, then it’s fine. Now if I’m trying to move slightly, the pcb goes to its smallest zoom factor, and I have a post stamp like picture (see first picture). Now if I move carefully to try to zoom in, I get a kind of rotated Ukrainian flag (see second picture) which is the tiny blue border of a mounting hole. If I stop Kicad and then restart it, I get a more normal behavior, but the steps are still huge, 5 steps per decade. So basically even when it works normally, the steps are huge. I have checked the forum history and this has been asked a few times. Programmatically, I suppose it would just be a matter of adding a few intermediate values in an enumeration, so I don’t think it’s a big deal. Adding preferences would probably need some more work. Is that kind of preference planned in a later version?

After reading the above there is:

  • One bug: mouse becomes erratic
  • One feature request: ability to have more intermediate values in the zoom menu.



Hi, roboya

I use a trackball without a wheel, and I am not the best person to answer your question. But I hate to see an honest question go un-answered. The default keyboard shortcut keys are F1 for zoom in at cursor and F2 for zoom out at cursor. I use those all the time (although I am using a nightly build version of Kicad.) Have you tried those shortcut keys?

Adding: Yes I just confirmed that hitting either key 5x gives me about a 10x zoom. But at least it does not take me 10 years to do that. :slight_smile:

With a little bit of math I would say it takes 5 years.

I can’t say anything about the erratic behaviour, especially when I don’t see any pictures.

In 5.99 it’s possible to set zoom “acceleration” (faster mouse wheel scrolling = faster zooming) and “speed” (zoom step amount). It affects only mouse zooming, not F1/F2 shortcut zooming.

Yes the math says about 1.58x per zoom. At least by my taste (People who know me say that I have no taste) the 1.58 ratio seems pretty good.

Hello Eelik!

I can’t say anything about the erratic behaviour, especially when I don’t see any pictures.

The point is that there is no way to take pictures. Imagine what you do with your mouse wheel to increase the zoom by 1 step (1.58). Usually moving the mouse just slightly increase the zoom by 1.58x. Now the erratic behavior is when this tiny step makes it change from 0.31to 3142. and the opposite slight movement makes it change back from 3142 to 0.31.

Let’s try pictures if you want:
First picture, the zoom is 0.31

Now I set the mouse over the mounting hole, and I try to slightly move the mouse forward to increase the zoom factor, and I get this:

This rotated Ukrainian flag exists at the limit of the plated hole. Look at the GND label, move to the north-east and after the end of the yellow zone, you have a grayish yellow zone and then a tiny blue zone. If you still increase the zoom, you get the picture above.

I have nothing against it, but the problem is that the zoom moves sometimes from its minimal (0.31) to its maximal value (3100 and some) without intermediate values.

And beside this, I understand that with keys, you can live with huge increments like this 10^0.2 factor, but with the mouse wheel, I would expect something smoother, like 5%. I find it simply too jumpy.


I suppose you use a normal mouse with a scroll wheel, and you try to zoom with the scroll wheel, and the scroll wheel works properly with other applications (so that it’s guaranteed that it normally doesn’t give more than one “click” at the time). Notice that the last one - the amount of scroll clicks - may be defined outside KiCad:


but at least for me it doesn’t seem to affect KiCad.

This shouldn’t happen, and I don’t know why it happens to you. There may be something with the mouse device drivers or something like that.

1 Like

Hello Eelik!
In fact, it doesn’t happen all the time, but when it does, I found no better way than stopping Kicad and then restart.

Just for info: Latest Kicad release (i.e. not nightly build). 5.1.6.
Windows 10.

Any chance you can try a different rodent, er mouse?


Thanks for your reply. 2 things:
This happens only in Kicad, all the other application work fine. Another graphical program I use quite often is CamBam (CNC machining), and I have no issue. Therefore I don’t want to alter the mouse behavior otherwise all the other applications would be affected.
I have many mice around, all of them Logitech. It doesn’t change anything.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.