Mouse Jumping Feature Removal


#1

Hi all,
I’ve recently started using KiCAD having been a user of Eagle and not being altogether happy with Cadsoft’s new(ish) policy on requiring accounts and online connection. I’m an engineer and I know every CAD package has its quirks - Eagle and KiCAD are no different. However, there is one quirk of KiCAD in particular that is absolutely driving me nuts, and seems to be unique to KiCAD too, and that is the “feature” that allows it to jump the mouse cursor around the screen. Now, I’m sure someone on the dev team has what has been deemed a valid reason to go against every platform’s UI style guides, but I can’t fathom what that reason might be. None of the many other CAD packages I’ve used over the years has or had such a jarring and intrusive feature. I’ve turned off the “Center and warp cursor on zoom” option, but that has only fixed one instance of this behaviour. Perhaps the most obvious time this occurs is when a context menu has opened, for example when clicking on a junction. The menu displays the possible selection options, but if you click anywhere other than on the menu, instead of escaping from the menu as in pretty much any other software package on any platform (not just CAD), the mouse is immediately jumped back to the menu to try again, which is totally unintuitive at the simplest of UI levels. Right clicking elsewhere has a similar effect. And even if you do escape the menu by giving in to its insistence that you choose one of the options, the mouse is still jumped to its previous location, which again is totally out of kilter with every other piece of software I can think of.

My feature request is this: Please, please, please add an option to disable this mouse jumping / mouse warping feature or whatever you call it. I’m sure to ask for it to be outright removed would be too crazy an idea for whatever devs have put that feature there in the first place, so having it as an option so that the few people who would like KiCAD to behave differently to every other piece of software out there can still have it that way. I know I’ve made some quirky design choices over the years in both hardware and software development, but by and large I know you have to have an extremely good reason to contravene accepted and documented usability standards.

Sorry if that sounds a bit ranty - I would like to like KiCAD, but after a dozen hours or so, it’s getting close to being uninstalled.


#2

It already is an option:

Preferences > General Settings
in the Pan and Zoom box,
Center and warp cursor on zoom

For what it’s worth, it takes about a week to get used to it. And when I finally got used to it, I liked it better than the other.

Here’s what I wrote on the developer’s list (I’m not a developer, just a supporter at the moment):

[Initially referring to cut/copy/paste keyboard shortcuts]
I think this is one of the things that make newcomers confused about the UI. Another is the pan cursor to zoom center. But I really like that functionality for mouse only navigation. You can turn it off then you have the more common “zoom using cursor as center of zoom”. Which are both much better than the other common technique of zoom from center regardless of cursor location. Kudos to developers for the more useful options (in my opinion). If the current operation wasn’t the default, I would have been less confused but would have taken me longer to find the better (in my opinion) current default.


#3

Hi HiGreg :slight_smile:

Thanks for the reply. Zooming isn’t a problem - it behaves much as it does in most other CAD packages. My issue is the mouse jumping. As I said in my first post, I’ve already disabled the “Center and warp cursor on zoom” option - that’s not the issue I’m talking about.

Issues like this shouldn’t be a matter of getting used to. To use the obligatory car analogy, I’m sure you could get used to driving a car with the accelerator and brake swapped after about a week, but you shouldn’t have to. And if you do get used to it, swapping back into any other car will then feel wrong. There are obvious and well-established UI paradigms that are used in almost every other piece of software on almost every other platform (not just CAD packages) that KiCAD ignores for no clear reason. I presume there is a reason other than just being different for the sake of it, which is why I suggested it as an option rather than removing it completely, so that those users who do prefer its non-standard behaviour can keep it that way if they wish.


#4

My apologies, I read too quickly and responded to an issue you had already solved.

I haven’t noticed the behavior you’re reporting, but I also haven’t looked for it specifically. What KiCAD version and OS type/version are you using?


Turn off mouse snapping?
#5

No worries :slight_smile:
It’s 4.0.6 (64-bit), and it’s on Windows for now. I would normally use it under Linux but I haven’t tried it yet. For specific steps to reproduce it, left-click on a junction in the schematic editor, then click anywhere, on or off the menu, with either mouse button. The mouse pointer immediately ends up back at the junction.


#6

I’m not sure why we have a Feature Request category, most people here are users. I am afraid it might give false hope :frowning:

Feature requests can be made on Launchpad, but with 300+ items on the wishlist, don’t expect speedy resolution. Changing KiCad behaviour that has been around since about day 1 is very low on the list of developer priorities.

Related issue https://bugs.launchpad.net/kicad/+bug/1666849


#7

Yeah, that’s a shame. I’ll stick a request on there anyway but for now I think KiCAD will be shelved while I try out some other options. Thanks guys!


#8

I am using a “nightly” build that is very old. I can not duplicate your issue.

If you are still reading for replies, I do believe that there are two nightlies that are known to be “decently stable” with several extra features over the “current .06 stable”.


#9

Irritating, yes. Even after two years of use of KiCAD it irritates me.
On the other hand, it just reminds me to have the left hand on the keyboard and to hit [ESC] when this happens (need it there for the shortcuts anyway, see [Shift]+[?]).

But I definitely agree, for mouse-only/centric workflows this behavioral catch-22 is hard (impossible?) to escape.

Would be nice to get an option in settings somewhere to enable ‘right-cliking outside of menu escapes menu’.


#10

OH! Can you provide an example? I’ve seen people that are extremely mouse-centric; and it never made sense to me. Even very early AutoCad releases had keyboard short-cut plug-ins taught at my local Community College; and that was a long long time ago.

I have a friend that is extremely picky about interfaces. He won’t use a program if it doesn’t work the way he wants it to work; even if there is a plug-in to change it to the way he wants it.

I’m glad that I am flexible enough to deal with the quirks I don’t like, and really enjoy KiCad for all the AWESOME it can do. <<<— Oh yea, I capped and bolded that … haters going to hate …

I think KiCad is great!


#11

Try to escape that menu with the mouse alone like you’re used to from any other context menu around windows…

(you get it by left clicking on the junction)

PS: I know that repositioning the mouse on the ‘X’ will get you out or right clicking somewhere outside will bring up the grid-context menu, which you then can escape by the expected way of clicking someplace outside the menu to make it go away.


#12

On my nightly of a WIN7 64 build, I do NOT get this to happen. Pointer never jumps anywhere.

I have to MOVE the mouse to get it to select anything in that pop-up window.

If I have a REALLY SMALL grid … oh yelling … really small grid

the mouse does “snap-back” to the origin of the junction.

However, I do not see that as a problem in any way.


#13

Try moving the mouse outside of the menu and rightclick to ‘escape’ it… same way you can escape the ‘grid context menu’.
It at least is inconsistent within KiCAD.

That’s different people for you.
I’m vaguely annoyed and just hit [ESC] when I encounter it and move on.
Still, it’s inconsistent behavior within the same GUI, as the ‘grid context menu’ doesn’t do that.


#14

I am still trying to find the issue… Just “right click” a second time, or preferably, hit the ESC key from the start?

You are going to have to give me step by step instructions on how these are in any way different.

When the mouse pointer gets “close” to several items, the “clarification” is annoying slightly, but very helpful.

Having the pointer “jump” to the “clarified item” is a problem in exactly what way? That seems like a really nice new feature to me.


#15

The complaint by the OP seems to me to be simply silly.

While WORD or EXCEL might not move the mouse pointer on different left/right mouse clicks, the purpose in a ECAD program is entirely different.

And, Warp and Zoom is just plain awesome!


#16

The issue is to leave that menu with the mouse alone as one is used to from the grid-context-menu.

Grid-context-menu (behaves like any other menu in any other CAD tool/GUI I have used over the last years):

Bring it up: right-click on ‘background’
Make it vanish: click anywhere OUTSIDE the menu

Item-context-menu:

Bring it up: right-click on the item
Make it vanish: …


#17

Previous versions didn’t have that ‘X’. If you really want to be annoyed try escaping that pop-up menu by clicking on the EESchema window title bar.

Another instance of mouse clicking annoyance is when using the toolbar button to select a different sheet. I think it only happens the first time you do it after opening the project, or perhaps after opening EESchema, but if the cursor happens to be over an object on the new sheet you get that “Clarify Selection” pop-up.


#18

Yep, there are a couple of inconsistencies in the GUI all over the place.

It will fingers crossed get better over time though :wink:


#19

All I have to do is move the cursor, with the mouse, to anywhere NOT in the pop-up menu, and do a second right-click on the mouse. Anywhere other then the location of the “clarify selection” the pointer moves to.

I like this feature.


#20

This is not unique to KiCad…

Try figuring out what left and right clicking on Word and Excel icons do.