Mouse bite footprint issue

I hereby certify that I am not simply asking someone else to design a footprint for me.

This is an auto-generated message that is in place on the “footprints” section of the forum. If I remove it and ask for a footprint to be designed anyway, I understand that I will be subject to forum members telling me to go design my own footprint or referring me to a 3rd party footprint site.

Currently trying to incorporate mouse bite footprints into my PCB but I keep getting the “board has malfunctioned outline” error.

Here is the footprint:

And the board outline:


Having trouble lining the footprint up even on a 1mm grid size.

Edit: Edge cuts layer is orange, I know certain parts are not in the edge cuts square but mainly trying to focus on certain parts of the board and have them split into sections, not concerned with the capacitor and two resistors for now.

What are those bluish circles?
Are those orange lines on Edge.Cuts? Did you change their color? (That makes it more difficult for others to judge what they are looking at).

The sides of mouse bites are often simply drawn rectangular, Rounding will then follow whatever radius the router bit has. For the small holes in the mouse bites. Those are often offset, so the center of those holes is at (or even inside) the “normal” PCB outlines. The way you have drawn them now, they will leave jagged edges sticking out beyond the PCB outline. Is that OK with you?

And what is this section of your screenshot:

If those orange lines are Edge.Cuts, then the LED and those two resistors are outside of the PCB.

1 Like

The bluish circles are part of the footprint, the edge cuts line I made orange to see easier, should have clarified that in the original post. In terms of placement I was trying to reference how certain people on YouTube did it, so I guess it’s just a matter of preference.

The board outline is not finished (I want that section finished for now to avoid the error ofc), a lot of parts right now won’t be part of it, mainly just doing testing and going to split it into separate sections.

I’m just having a hard time lining the footprint up, despite trying different grid sizes.

This is what the manual (under “Help”) says about Edge.Cuts.

4.7.3. Board outlines (Edge Cuts)

KiCad uses graphical objects on the Edge.Cuts layer to define the board outline. The outline must be a continuous (closed) shape, but can be made up of different types of graphical object such as lines and arcs, or be a single object such as a rectangle or polygon. If no board outline is defined, or the board outline is invalid, some functions such as the 3D viewer and some design rule checks will not be functional.

As long as you have:

then you will also have:

Those are the same thing.

1 Like

Right, the entire “board outline” all with their sections is not finished, but that one particular section is finished, there are only gaps between the mouse bits, which I saw on the Youtube videos I watched.

Hi @drtech98

Please read this section of the Kicad Documents.

Your original post shows several boards on the one project. You need to change the Edge Cuts outline so there is only one board. The board outline is then finished and DRC will not complain.

1 Like

I’m also surprised seeing it. My mouse bits didn’t show that, but I am still in V7 so may be in V8 for arcs there is extra showing of their construction.

1 Like

I also made a footprint for a mousebyte. The mousebyte is made using a certain gridsize. So when I place it in the PCB whilst the gridsize is set to 0.5mm all the connection points are always on grid.

I have had certain situatiations where this was not the case. If the connection points happen to be ‘off-grid’ you can snap an other edge cut line by selecting the line itself, than select and drag one of it’s outer points on top of the connection point. They should snap and be allright.

I hope this screenshot shows better.

I put the mousebyte off grid manually. Than I selected that left line and I dragged the top of that line on top of the mousebite and it snaps into a perfect fit.

Usually when all is already on grid, everything snaps in place when you place the lines.

This may fix your problem, but I do recommend to find out what is wrong with your mousebyte* footprint and repair the footprint.



*pun intented


KiCad has: PCB Editor / Tools / Cleanup Graphics, and this has an option for: Fix discontinuities in board outlines.

I would be wary of using this function though. It does seem to “fix issues”, but not in a very neat way. It is typically one of those things I rather do manually, and do it right, then rely on some tool that generates results of which I’m not sure whether it fixes or hides a problem.

I guess it could be used, if you follow it up with a manual check of each transition between graphic entities.

But as bask185 also mentioned, designing the PCB outline on a simple grid (such as 1mm) and doing that for mouse bites and other footprints for the PCB outline is probably the best option. KiCad is not very good at graphical stuff, and simplifying graphics wherever possible makes both design and maintenance easier.

1 Like

I got it to work, I’m not sure what I was thinking, but I adjusted the footprint got rid of the blue circles, added edge cut lines (I made the edge cuts layer orange), and lined up the 2mm mouse bite footprint with my board. I guess what was throwing me off was the arcs being drawn in the front silkscreen layer instead of the edge cuts layer.