Mounting pads not connected


#1

Hello!
I have used mounting pads in my schematic and tried to assign a footprint to them. The problem is that they are not connected (or at least reported as not cooncted) and there is an air wire I can’t get rid of. Does anybody know how to get rid of this air wire? I tried other footprints, no way.

By the way, I’m not sure this is a bug or a feature, but when I zoom, the mouse pointer is systematically moved to the center of the drawing area. On many other systems, zooming keeps the current pointer place and enlarges or squeezes the areas around it.

Thanks for any hint. Especially about the air wire.

Pascal


#2

Preferences -> General settings ->Pan and Zoom -> Center and warp cursor on zoom

Is the zone around the mounting hole GND? If so, check the GND net name. It could be /GND.

Edit: sorry, if the mounting hole is connected to GND in the schematic the net name should be correct. I was thinking of a mounting hole added directly in the layout.


#3

The air wire doesn’t necessarily mean that the mounting pad is unconnected. It could in this case also mean that C31 has no connection to GND and that the mounting pad is simply the closest thing that is connected to GND.


#4

I think there is a bug, certainly a “feature” in this footprint. The via holes are not assigned a pad number, and may* prevent the zone fill reached the center of the actual GND pad, which is what the DRC uses to test if connected (in fact the copper of the pad will connect OK, the DRC doesn’t know that).

* depending on zone settings

Simplest workaround is to explicitly draw a trace to the center pad.


#5

The new lib will have them fixed https://github.com/KiCad/kicad-footprints/pull/239


#6

Wow, that was quick :smiley:


#7

Hello Pedro!

Thanks! It works (more or less) but it’s quite buggy. Everything should inflate or deflate around the mouse
and the mouse itself should not move. Actually it does. A way to reproduce it: point to a certain component.
Move in / move out. After a few cycles I’m not on the component anymore, and sometimes out of the sheet area.

About the connection itself: apparently a bug was solved. I’m going to check. Thanks!

Pascal


#8

Not in the footprint lib that is used by the github plugin for kicad 4.0.x. The repo is already archived (read only).

So if you want to use the new footprints, you will need to download them manually from the download page https://kicad.github.io/footprints/MountingHole (The zip file will be updated sometime next week). Or if you can not wait, directly from the github repo https://github.com/KiCad/kicad-footprints (Use the clone or download button.).
You then need to manually add this lib to the fp-lib-table. (Remove the current Mounting_Holes entry and add the new Mounting_Hole lib in its place.)

I would not suggest a full switch over to the new lib for old projects. A lot of incompatible changes have been made to the lib.


#9

Hello Rene,
Thanks for your reply.
How to I access the fp-lib-table?
And by the way, where should I copy what I have downloaded?
Pascal


#10

To remove the old entry:
pcb_new (or fp editor) -> preferences -> footprint library manager

Adding new stuff either via
pcb_new (or fp editor) -> preferences -> footprint library wizard
or use the append with wizard button in the library manager

Anywhere you like.


If you downloaded from the github.io download page, remember that this zip file is only updated once a week. This means the freshly made changes are not in there yet. (Edited my comment above to highlight this fact even more.)


#11

Hello Rene!

Thanks for your reply. I tried, and I don’t know what went wrong, but it’s exactly the same, I still have the air wires, exactly the same as previously. As for the lib manager, I didn’t unchecked, I removed the mount hole library, and added the new version with the wizard.
Beside this, I have verified when assigning the footprint that the path is correct and corresponds to what I have downloaded.

Thanks,

Pascal


#12

Where did you download it from? I say it one more time. The github.io zip file might not yet have been updated you really need do download the repo directly until there is a new build. (Which will happen next week.)

You will also need to assign the new footprint in the schematic. And you need to export a new netlist and reimport it. (make sure you select change footprints)

Maybe check that you have the fixed footprint via the footprint editor.


#13

Hello!
Thanks for your time. As I wasn’t 100% sure, I downloaded again from Kicad (not the kicad.github.io,
the “if you cannot wait”…).
I could observe that the file has been changed 13 hours ago, which corresponds more or less to
the time you did it (yesterday night in Japan time).
Summary of what I did:

  1. Download (see above)
  2. Remove the lib Mounting holes from the pcb_new menu-> footprint library manager
  3. Remove the library physically on the disk, and add the one I have downloaded in (1).
  4. Added the new one using the wizard
  5. Just in case, opened the schematic, changed all the footprints assignement for the 4 hole items
  6. Exported the net list
  7. Imported the net list from the layout editor

Result: the air wires are still here. I pushed B just in case, to refresh the drawing.

Is there anything wrong in this sequence?
Best regards,

Pascal


#14

Does your footprint now have pad numbers assigned to the small holes?


#15

Hello Rene!
Thanks for your reply. The pads have a 1, that’s it. I don’t see small numbers… wait, I have to zoom… yes there are small numbers on the small holes. All the numbers are 1, then GND.
Today, I was working without paying attention to the air wires. I made an update of the nightly builds, and now there are no air wires anymore. I’m not sure exactly when it disappeared. I upgraded once just after my last message, and then was working on my layout. Then I noticed that there is even a newer nightly build, so I upgraded again. And now the pads don’t have airwires… And I didn’t try to zoom them this morning. But I didn’t change them either. So I guess there was something with the last nightly build.
Sorry for the mess…
And many thanks for your time.
Pascal


#16

There have been some regressions and subsequent fixes in the nightly builds relating to zone fills and the handling of thermal relief “spokes”, so you may see some unusual behaviour in particular builds. There appear to be some outstanding bugs in zone filling yet to be fixed as well.


#17

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.