Module and 3-d name changes with 5.1.6

Using V5.1.6 references different names for components and 3d models. Now I cannot render any 3-d images and the PCB DRC reports errors because many of the names are changed. For example R_0603 has been renamed to something different.

I had no problems with V5.1.4

I understand why ichanging names might be good moving forward, but it’s a total disaster at the moment. 3-d rendering only shows holes–not even a PCB.

Anyone else had this problem? Is there a fix other than going back to an earlier release?

It would be easier to locate the problem if you give some actual full examples. Names hasn’t been changed in the official libraries within v5 series. The last time a major change was made was between v4 and v5.

EDIT: this was the change: I had KiCad 4 installed previosly. Now i updated to v5. Now i have some problems with the library setup. Do you have something similar or completely different? Give enough details so that we can help.

Something went horribly wrong. None of my 3D renderings work now. Even when I try to import them directly. Here is a rendering of a pcb.
image

If I try to update a part with a known 3d object, it never appears.

I tried both 5.1.4 and 5.1.6.
I did upgrade to Win10 Pro (the latest Spring release), but my associate has Win10 (personal) and has no issues with 5.1.4.

So 3D is non functional. Can’t render anything–not even a bare PCB. Could it be an issue with the latest Win10?

I guess it could be a driver issue. You can try to update the graphics card drivers.

Is your image a screenshot from the 3d viewer or exported png?

What happens if you export the 3d model from pcbnew and open it with another program which can show it? Or if you use FreeCAD with StepUp and load the board file there?

I get 3d if I use ray-tracing, but doesn’t show 3d in the part editor.

this is EXACTLY the same issue as reported here with a Dell Precision laptop:

https://bugs.launchpad.net/kicad/+bug/1815286

the last entry says,

But I’m not sure what he means. Can you help?

Brad

The issue is now https://gitlab.com/kicad/code/kicad/-/issues/2547.

What is that which is said you don’t understand?

See the last entry

Thank you for the pointer. I’ve just created a KiCad profile, making only a single change to the default setting, and it’s now working for me too! The only change I made was to switch Anti-aliasing Mode from ‘Override application settings’ to ‘Use application settings’ and it’s now rendering correctly!!! :slight_smile:

how do I make changes to the default setting as described.

It’s totally about the video driver (AMD Radeon graphics card/driver), not about KiCad.

1 Like

OK. Seems I need to get the Radeon tools. Let me try that…

Yes! It now works (so far). It seems going to Windoze 10 caused the issues. Never had a problem with Windoze 7.

1 Like