Missing symbol table on archlinux

Hey, i have an issue with kicad where i get this error when i try to start a new project
image
Rather annoying, what should i do to install such a table? In my .config i do have the fp-lib-table file with the correct data in it.

Im running on arch (see image)
(apparently i can only upload one image soo uuh)
- System information .o+ OS: Arch Linux
ooo/ Host: Nitro AN715-51 V1.05 +oooo: Kernel: 5.15.12-arch1-1
+oooooo: Packages: 1375 (pacman) -+oooooo+: Shell: zsh 5.8 /:-:++oooo+: WM: awesome
/++++/+++++++: Theme: Arc-Dark [GTK2/3] /++++++++++++++: Terminal: kitty
/+++ooooooooooooo/
./ooosssso++osssssso+ Hardware information .oossssso-````/ossssss+ Uptime: 1 day, 22 hours, 4 mins
-osssssso. :ssssssso. CPU: Intel i5-9300H (8) @ 4.100GHz
:osssssss/ osssso+++. GPU: Intel CoffeeLake-H GT2 [UHD Graphics 630]
/ossssssss/ +ssssooo/- GPU: NVIDIA GeForce GTX 1650 Mobile / Max-Q
/ossssso+/:- -:/+osssso+- Memory: 4371MiB / 7791MiB +sso+:- .-/+oso:
++:. -/+/
. /

I also attached some kicad info below

Application: KiCad

Version: 6.0.0, release build

Libraries:
wxWidgets 3.0.5
libcurl/7.81.0 OpenSSL/1.1.1m zlib/1.2.11 brotli/1.0.9 zstd/1.5.1 libidn2/2.3.2 libpsl/0.21.1 (+libidn2/2.3.0) libssh2/1.10.0 nghttp2/1.46.0

Platform: Linux 5.15.12-arch1-1 x86_64, 64 bit, Little endian, wxGTK, awesome, x11

Build Info:
Date: Dec 30 2021 00:19:57
wxWidgets: 3.0.5 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.78.0
OCC: 7.5.3
Curl: 7.80.0
ngspice: 35
Compiler: GCC 11.1.0 with C++ ABI 1016

Build settings:
KICAD_USE_OCC=ON
KICAD_SPICE=ON

In Ubuntu at least, that global default table lives at /usr/share/kicad/template/sym-lib-table – is it the same in Arch? I’m not sure why it would be able to find the default footprint table but not the default symbol table unless there is some weird Arch packaging situation.

image
Only thing that i have in that directory

According to Arch Linux - kicad-library 6.0.0-3 (any) you will need to have the kicad-library package installed in order to get the default library tables. Unfortunately I am not familiar with Arch so I don’t have any specific advice, but it looks like you are missing that package or else it wasn’t installed correctly. Seeing only kicad.kicad_pro in that folder implies that kicad package is installed but kicad-library is not.

2 Likes

Ah perfect, the solution was basically to install that package yeah

sudo pacman -S kicad-library

Thank you very much

2 Likes