Missing stop & cream mask (solved)

Why can’t I see the stop and solder mask of the pads of the part
https://github.com/Blunk-electronic/kicad-training/blob/master/lbr/resistors.pretty/R_0805.kicad_mod ?
I the device model file itself seems to have them (inspected with a text editor), but the footprint editor does not show them (checks on stop an cream on). What is wrong ? Thanks.

OS : OpenSuse 42.1 Leap 64bit
Kicad: V4.0.4

I just checked your file. Looks good to me.
In the 3d viewer it should look like this. (The gray part on top of the golden pad is the F.Paste layer. The cutout within the green stuff is the result of the F.Mask layer.)

In the footprint editor it looks like this. The violet part is the F.Mask layer. Red is the pad itself.
The Paste layer is not visible here. You can see the paste layer if you select the past layer in the layer selector (blue arrow is next to paste layer)

Did you by any chance somehow set the mask clearance to 0 in your kicad template project?
(The footprint editor shows the clearence of the standard template.)

Edit: I just looked at your project within the same repository. There you set the solder mask clearance to 0. Which means the mask (cutout) is not bigger than your pad. Set it to something that makes sense for your manufacturing process. You can set it in pcb new under dimensions->Pads and mask clearance

thanks for your reply. Your second screenshot shows what I miss on my system. The checks (on the right) are all set. Turning on/off copper layers or silk screen works fine. But stop mask and cream don’t go on or off. That is the point.
I didn’t change the mask clearance to 0. I took the part from the SMD 0805 resistor library shipped with KiCad.
The effect is visible with other SMD parts I randomly picked out of the libraries.
The effect is also visible in the layout. Setting the checks for mentioned layers does not turn them on.
cheers, Mario

Yes you could set the clearance in the footprints. But the standard footprints are set to 0 which tells kicad to use the project settings.
Each project has its own clearance settings please check the settings in pcbnew->dimensions->Pads and mask clearance. When i check your projects settings i see that it is set to 0.

Here is a screenshot of your project: (With your settings)

And here is your project with the clearance set to 0.1mm. I also set the min width to 0.1mm((This values depend on your manufacturers capabilities. please check their documentation on how much clearance is needed.)

1 Like

ok, thanks so far, but in your screenshots I can’t see the stop and solder mask, despite the checks are set. so it seems you have the same issue on your side. or am i wrong ?

The second one clearly shows the solder mask (the violet stuff around the bright red pads) The mask layer is the F.Mask layer
What layer did you expect?
The F.Paste layer is not visible in this screenshot because it is hidden “behind” the bright red pad.

The pads of this footprints don’t have any other layers activated.

You may need to activate the new OpenGL canvas to see some of the layers. Hit F11 to activate the canvas, if your KiCad version has it.

you are right. I did not see it at this time of the day. sorry.

Thanks, the OpenGL thing made the layers visible. The fact that the mask is exactly the same size as the pad combined with the Open GL disabled was the issue. Case closed.