Missing schematic libraries on 4.0-RC2

Hi
I just installed the 4.0-RC2 on Linux Mint and have no schematic libraries at all.
I reinstalled it, with the same result.
Am I the only one with this?
Thanks

But how? I’m having the same problem. I’ve downloaded kicad-library repository from github and added it’s path to library paths. Problem is this is added to the project. How can I add a library path for kicad installation?

hi @hyOzd,
welcome to kicad forum! :smile:
if you need to add a library from github to a global library configuration,
you can use the library wizard…


and select to add it globally

that will modify your global ’fp-lib-table’ configuration table

Maurice

Hi Maurice,

I’m talking about schematic libraries. I thought fp-lib-tables was only for footprint libraries. Am I right?

you are right, it is only for pcbnew, sorry I didn’t read the previous post that your prob was in schematic…
I think you could create a template so your next project will have the same libs
If you create a new project you don’t have any eeschema lib?
I don’t have this prob… It could be related to RC2…

in your share installation folder you should have a kicad.pro file which is used for the new project creation…
this .pro file contains the schematic lib list…
in windows is located in ‘C:\Program Files\KiCad\share\kicad\template’

Thanks for the suggestion. But this doesn’t solve the portability problem. I’m working on this project from 2 different computers, and library paths are different. Each time I move to other device, I have to make sure the paths are correct.

By the way I think this happened because they have removed package kicad-commons from the ppa repository. I remember uninstalling it (automatically of course) in a recent update.

for portability I think you could add search path for library to your schematic


that should let you move the project to different kicad PCs with different libs location
[edit] but if you are in position to handle the pc configurations, I would keep both aligned, so to avoid any headache :smile:
I use to do it with my pcs

Adding it that way will insert the path to project file.

Putting libraries to the same path in different computers isn’t always possible. Different operating systems, different people… There must be a way to set the library path independent of the project.

but if you put both of your path (pc#1_path, pc#2path) it should work…
it is a workaround anyway

Well that doesn’t work either.

When you are on PC2, if you open the paths dialog and add the PC2/path, you will see that kicad removes the PC1/path, presumably because it doesn’t exists (in PC2).

On the other hand, I found the missing libraries. They were in a debian package named kicad-library. I’ve installed it and now I have symbols library in “/usr/share/kicad/library/”. It’s detected by eeschema as well.

Question is; why was it removed in the update? When I look at the properties of the debian package kicad, it has a line: conflicts: kicad-common. This is the reason why when I updated the kicad package, kicad-common package was deleted. I’m guessing devs did a change in the package structure and now kicad-common package is deprecated.

Although I solved my problem, I would like it if there were a method to add a system wide library search path.

an other trick is to bring the libs with your project, giving a path relative to your project…
that is an option that will give the assurance that your lib objects will be the same in difference computers, and they will not depend on local libraries modifications
(schematic symbols are very light)

The Debian packages have to follow some strict rules on how and where things get installed, maybe something to do with that.

I’ve always used relative paths to link to schematic libs, I hope that still works in v4…

I already to this for symbols that I’ve added. I carry them around with my projects. But I don’t want to this with the whole schematic library.

The libraries should be installed with the software, or there should be clear information how and where we can download and install them.
It is strange that the people have to post into user forum to get that information.
Meanwhile, I did the update to the 4.0.0 release, hoping it will solve that issue, but the situation remains the same.
Thanks for Your help

1 Like

Solution for the Debian, Ubuntu, Mint and other Debian-Linuxes is to manually install the kicad-library:
sudo apt-get install kicad-library
Maybe the libraries will be contained in the installation package some day again, for now You have to do it by Your self.