Missing option "Leave islands" or "Leave isolated areas"

So, in order to have islands we have to choose “no net” for Zone Net.
What I need is to select GND for my Zone Net, but also have islands (not to get them automatically removed).
It would be nice to have check box “Leave islands” in the Copper Zone Properties box.

I made this same question to the developers mailing list. Apparently it was never (and maybe will not be) possible to have isolated islands on Nets.
So maybe the workarround will be to add a second copy of the zone with no net (with different priorities) so it will fill the gaps?!..


Yeah, just clone the zone and assign it to ‘no net’.
Also priority settings need to be adjusted then I guess, so the zone with the net has a higher priority for filling than the one that just fills in the islands.
Piece of cake :grinning: