Missing footprints kicad 5.1.8

I recently installed a kicad 5.1.8 on my windows 10 laptop, previous version I used was installed on my desktop windows 7 and was working without any issue.
i installed this version 5.1.6 and completed the schematic , now I am assigning the footprints and getting this error footprints are missing. The symbol mostly involve in my schematic are already available since installation, but now their footprints are missing.
I try to get installed some footprint libraries from github, but I didn.t get all of the components mostly controller and driver ICs which are showing up in the symbol library.
Did I made some mistake while installing the software or some other issues here.
Do I go for the other version or is their a way to fix this issue, please suggest.

We are kind of flying blind here. At least one error message would be helpful.

This error message I am getting,
no pcb footprint libraries are listed in the current footprint library table.

Just downloading some library files does not make them visible in KiCad. KiCad only uses the footrpint libraries that are added to the fp-lib-table file. You can add them from within the project manager:
Kicad / Preferences / Manage Footprint Libraries

For more about library management, see:

But during a normal install lots of footprint libraries are added to KiCad, so I wonder what happened there.
When installing and then running KiCad for the first time it asks some question about libraries (I think). I always added them. I do not know what happens when you select no there.

Thanks, I appreciate your guidance, I had selected those option, I also wonder if the symbol are available after installation their footprint should also be visible.
Should I reinstalled this software.

There are certainly good reasons why symbol and footprint libraries are separate things like schematic and pcb editions are also separate things. As they are separate then from visibility of one you should not expect visibility of second. And also symbols don’t have something that can be named as their footprints. Symbol can have its default footprint but as you can change it you need not to have it available if you don’t wont.

There are ways to fix errors or modify the settings of KiCad, but if you have not made important changes to the settings yourself, then a complete uninstall and re-install of KiCad is probably the simplest.

Installation procedures also vary depending on the OS you are using. On Linux distributions for example, KiCad is divided over several packages, and if you only install one of those packages you only get a part of KiCad, but installing the “main” KiCad package usually installs the binaries, Libraries and documentation.

Once again thank for the informative support,
I try to reinstalled the software and see if it works.
Thanks and regards

Reinstalling will not fix anything. The library tables are part of your personal settings and they are not touched by the installer. You either need to manually add the footprint libs to the library table OR you need to reset the library table (which is done by deleting it)
See Library management in KiCad version 5

How you got to that state is beyond me to be honest. My only guess would have been that you had an old installation of kicad on this machine with a left over library table or you deliberately deselected installation of footprint libs during the installation process. (By default all libraries are installed. When you then run pcbnew and eeschema the first time then the library tables are setup.)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.