Missing footprint TQFP32


i’m getting the following error " footprint ‘TQFP32’ was not found in any library" after “assign component footprint” on macos.

does anyone know how to solve this?

thanks in advance

Which KiCAD build are you using?
Maybe the schematic symbol has a footprint assigned by default which does not necessarily correspond to the name of the actual footprint in the footprints library.
Try changing it in cvpcb to the actually available TQFP32 footprint (should be in the Housings_QFP library for recent builds).

kicad-r5578.20150704-034703.dmg and
kicad-extras.20150304-122823.dmg on MacOs.

i have opened this thread.

until now no response.

Yep I’m pretty sure the schematic symbol for the ATmega has a footprint already assigned. In the schematic editor right click on the symbol and select Edit component>Edit.
In the component properties window, there’s a field called footprint. Simply delete that value and hit okay.

Now when you open the footprint assignment you shouldn’t see an error. Select the correct footprint in cvpcb, rather than putting it in the schematic first.

in cvpcb, doesnt appear any footprints of atmegas.

there are only footprints of passive acitv components and sockets.

same issue

What is in your fp-lib table?

I highly doubt the bug you’re mentioning is related to your situation…

Try to download the KiCAD TQFP32 from:
(choose download to KiCAD format)
the file comes .mod file. Change the extension to .kicad_mod from Windows, then open it through KiCAD PCB Foot Print Editor & export it to a new location. This worked with me. It should work with you too.

Isn’t this what you want in the official Housings_QFP.pretty directory?

The original post is more than one year old. The original poster did not update his situation. This suggest they either solved it without sharing the solution or they gave up.

1 Like

Unless there is something unusual about the required footprint, avoid 3rd party sites like @AKB suggested if there is an official one. It is better to fix errors in the official libraries.


But why are TQFP footprints called “housings” and kept separate from other SMDs? Confused the heck out of me.

I would probably have chosen “package”, it’s in the name after all. I would use “housing” as another word for “enclosure”.

I guess english just has too many words to choose from :slight_smile:

I would have chosen IC_Package_xxx. Housing implies a module or can like one of the old crystal oscillator modules

The problem is still there. I’m trying to use the same package now in Sept '17, KiCad 4.0.7 for Windows.
I suspect the original package is broken somehow. It can be viewed in the footprint browser, but not imported into a board. Looks like I’ll have to download an aftermarket part or roll my own.

Working here by a direct place footprint

I have recently created a (small) number of library parts and footprints as my 4.0.6 version of Kicad doesn’t have these or can’t find them in the (standard) paths. These include QFP_20, Arduino Mini Pro (one specific Chinese clone) and TQFP_44 footprints, and libraries for the Arduino Pro Mini and ATtiny816. (that is, amongst others not relevant to this question). I have recently begun thinking of submitting them to the community but haven’t gotten round to it yet. Not gonna happen today I’m afraid, other priorities have precedence ATM.

I’d like to see them so that I can add them to my library!

Yeah, that works, but the netlist is missing.
I’ve got mine working my importing the footprint into my personal favorites list. I’m not sure what the difference is, I expect there’s a bigger issue with the ‘housings’ set itself. The footprint itself is good.