Minor errors after upgrade

Hi @ChrisGammell-

After the upgrade, the flair are being served over http://, which is blocked in Chrome for mixed content (unless users change the default setting)

1 Like

Ah, that’s actually on me, I must have typed in the address wrong. It should be fixed now and should propagate shortly.

1 Like

I see a lock on the Chrome toolbar now, I assume this is good for you now?

1 Like


All good now

It seems that kicad_pcb extension files wouldn’t get correctly handled
see i.e. this file
bspline-dxf.kicad_pcb (3.3 KB)

Hunh, that was never added to the authorized extensions on here. I just added it, might take a bit to propagate. Did it work in the past?

If I remember correctly it worked.

it seems that also other kicad extensions were allowed and are not working anymore:
i.e. ‘.kicad_mod’
‘kicad_mod’ allowed to upload but not for download

Hrm, I tried what you said and agree that it’s not there. I can’t tell if it’s actually not uploaded to the server or if the downloads aren’t allowed.

Here’s a test file from me as well: cartprotoboard.kicad_pcb (280.0 KB)

Just tried.

It leads to this answer

Oops! That page doesn’t exist or is private.

Yeah, I think it might have been that the default “allowed” extensions changed. They used to be “.jpg” instead of “jpg”, but I just saw that it’s different. I tried adding the new extensions as well:

Trying the attachment again: cartprotoboard.kicad_pcb (280.0 KB)

Starting to think it might be the underscores. I’m going to do some more research with the underlying forum software (Discourse)


SensorBoard.kicad_pcb (58.9 KB)

HEY HEY, it works!

The underscore problem has been fixed!


Great! This was really getting on the nerves…

Yeah, it’s pretty critical for us to be able to share the basic files of the software we’re discussing on here. I appreciate everyone’s patience, we had to wait for the bug fix from the devs, but they came through.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.