Minimal distance between VIAs

Hi, I’m new with KiCad.

I am make my circuit with Kicad and I am using TopoR for autorouting.

My problem is how to set minimal distance from vias.

My PCB maker says that “The space between holes is less than 0.35mm”. Can I solve this problem?

Settings are in Pcbnew

  • File | Board Setup… | Design Rules | Constraints.
  • For quick access click the second icon top left.

Uhmm… are these settings? (my KiCAd is in Italian)

Please post your KiCad version info from Help | About | Copy Version Info

Looks like an older version you are having there.

Application: KiCad
Version: (5.1.4)-1, release build
Libraries:
wxWidgets 3.0.4
libcurl/7.61.1 OpenSSL/1.1.1 (WinSSL) zlib/1.2.11 brotli/1.0.6 libidn2/2.0.5 libpsl/0.20.2 (+libidn2/2.0.5) nghttp2/1.34.0
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.68.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.61.1
Compiler: GCC 8.2.0 with C++ ABI 1013

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_PYTHON3=OFF
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_WXPYTHON_PHOENIX=OFF
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_USE_OCC=OFF
KICAD_SPICE=ON

In this case it is Regole di progettazone (Design Rules).

1 Like

A tip for the future: switch the software you have trouble with to english before making a screenshot to be posted on an international forum.

For kicad this can be done in the main window -> preferences -> language

1 Like

Als Europäer sind wir da schon sehr flexibel. :sunglasses:

1 Like