Micro and burried vias


#1

I cannot find a property for the vias that says it will stride layer x to y

dont know how this is supposed to be set up/done.

need to do some micro-vias

L1-L2
L2-L3
etc


#2

Tools -> Set layer pair

At least in legacy canvas. I’m now with a laptop that can’t run opengl and I can’t recall how the layer pair for vias is set in opengl canvas.


#3

Same under open-gl (kicad 4.0.6)

In addition: micro vias need to be activated in the design rules.


#4

Nope

I dont get it.

I can set layer pair yes, but only 1 pair as far as I can see

In this case i simplified it to a 4 layer board

how do a I route a trace with microvias from top to bottom ?

L1 -> microvia -> L2
L2 -> microvia -> L3
L3 -> microvia -> L4

in my example it appears as stacked micro-vias but you could have a bit trace on each layer


#5

One pair at a time. The pair can be changed every time you need.

My advice: check some manufacturers’ web pages. They tell what pairs are allowed or not and why.

From your example, it looks like you need a L1->L4 via, that is also connected at layers 2 and 3.


#6

Hi

I have no problem understanding what manufacturers can do.

I want staggered microvias.

L1 trace L1 - > L2 micro via - > trace on layer 2 > burried via L2 > L3 > trace on L3 > micro via > L4

Other tools let you keep a via library and pick you vías.

Chosing properties on a via in kicad you are unable to change its type.
What layers it’s should stride over.

I’m afraid I will be pushed over to another tool to fix this.

Multi layer air inductor as part of PCB.


#7

Hello to every forum user.

I am using KiCad 4.0.7 on Ubuntu.

I have also problem with microvia.

I have 2 problems.

The original setting of “Layer Pair” is F.Cu- B.Cu.

In my installation there is no “Set Layer Pair”, only “Layer Pair”, but I am able to change the assignment of the “Layer Pair”.

Even using “Layer Pair”, it results impossible to create microvia between anything else than F.Cu-In1.Cu (Top-L1) and B.Cu-In8.Cu (Bottom-L8).

Even if I sets In1.Cu-In2.Cu (L1-L2) or In1.Cu-In8.Cu (L1-L8) as a pair is impossible to create a microvia between them. It continues to be possible to create microvias between F.Cu-In1.Cu (Top-L1) and B.Cu-In8.Cu (Bottom-L8) even when F.Cu- B.Cu are no longer a Layer Pair.

Does someone else have the problem described above?

If I do not simply need staggered microvias, is stacked microvias possible in KiCad (4 or 5)?


If I am not able to solve these problems I am probably forced to use Mr. Bastian Neumannthe code

Thanks every one for your time.


#8

These are the other two links (I am a new user, so I am limited to 2 links for every post).


#9

Are you talking about blind/buried vias or blind/buried mirco vias? For blind/buried vias you can try ALT+< (on my keyboard (US qwerty) alt, shift, comma) which should pop up a small layer chooser to allow you to pick the target layer regardless of your layer pair configuration. I don’t know if this works with micro vias or not.

(FWIW I’m on Win10 running a recent v5-rc1-dev, and verified this in the OpenGL canvas.)

I’m sure you are being carefull, but remember not all blind/buried via targets are possible depending on your manufacturers process. I don’t think (but could be wrong) there are any DRC setting to flag unusable blind/buried vias.


#10

Hi, thanks for your answer SembazuruCDE.

I confirm that blind/burried VIAS are working (under Linux is Shift + Alt + V) . In particular, they follow my selection of Layer Pair in “Layer Pair”.

But I also confirm that MICROVIAS are NOT working with “Layer Pair”. They are only available between F.Cu-In1.Cu (Top-L1) and B.Cu-In8.Cu .

KiCad is only ablle to create HDI 1+xb+1 buildup (http://www.we-online.com/web/en/leiterplatten/produkte_/microvia_hdi_leiterplatten/multilayer_aufbauten/Multilayer_Aufbauten.php) or similar, it is NOT able to create 2+xb+2 or more.

The only 2 ways around that I could think about are:

  • use MICROVIA as a “Custom via” under “Design Rules Editor > Global Design Rules” (but is necessary to check if that is ok and this make not useful the minimum values for Vias9
  • use Mr. Bastian Neumannthe code

Thanks for your time


#11

No problem. I’ve never needed to use microvias nor blind/buried vias, so I only have anecdotal information and cautions. Thus I don’t think I can help you further. I hope you are able to solve (or at the very least kludge your way through) your issue.


#12

can you upgrade to latest nightly and reconfirm

i also suffer from this limitation forcing me to do micro-via designs in orcad

I have not checked in later nigtlies as i am not doing micro-vias for the moment.

I also think kicad has a problem/limitation with flex/rigid pcb where the number of layers vary within 1 single pcb.