Metallized holes betwen 2 layers

*I hereby certificate that I am not asking someone else to design a footprint for me.
Hi everybody. I just registered., I have a question with version 5.1.7-1 about pad settings. How to be sure that all holes are effectively plated (metallized) on a 2 layers PCB. I have a FRENCH version. I didn’t find something pertinent.
I could insert some image, but I dont know how…
Thank’s for any help.

Final answer would be to generate a set of Gerber and drill files.
KiCad generates two drill files. One for PTH, and one for NPTH.

You can also look at your PCB in the 3D viewer, and then disable the PCB material and the Solder Mask. This makes your PCB transparent and you can see the via’s in between the copper layers.

You may also consider an update of KiCad. The current version is V5.1.10. and this has a bunch of bug fixes compared to the V5.1.7 which was released on 2020-09-30

Why did you start with such an old version? If you follow the instructions on KiCad’s website, you’ll always get the current version.

Component pin holes and vias are plated automatically. The only common NPTH holes are various mechanical fixing holes eg MountingHole
MountingHole_Pad is plated and is intended for grounding a board to a standoff

Hi, Thank’s paulvdh and davidsrsb for your quick answer.
I sent gerber .drl file to JLCPCB, and I think I made a mistake…
I generated this file with the box checked : metallized and non-metallized holes in 1 single file
I looked to this file and I noticed that line 5 (; #@! TF.FileFunction,Plated,1,2,PTH) that we have in the PTH file (box unchecked), was not present in the file I sent to JLCPCB. I contacted them, but they can’t give me any response on what will be make. Did anyone have encountered such a situation
and would know the outcome? I’m afraid I’ll just have to wait and see…

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.