Metadata.json archive missing


When installing zip files from the KiCad download directory, and using the Plugin and Content manager i receive the following error at the end of the install

Archive does not contain a valid Metadata.json file

What am i doing wrong or how can i solve this issue?

The manager doesn’t handle just any zipped plugin. It needs a metadata file which describes the content. You can install a plugin not prepared for the manager by unzipping it to a certain folder.

Edit: if you give step by step description about what you are doing and file paths or links, you may get better help.

Okay i understand that it needs a metadata file, but i would assume if i download a file from KiCad like kicad-symbols-master i would contain this file.
If i want to unzip it myself and put it in the file as you mention, were is that going then?

The steps i follow. I download the file from the Kicad directory. Then i go to plugin and content manager. From there:
Install from file

Plugin and content manager can only install zip files that are KiCad packages. What you downloaded isn’t one.

Based on the name kicad-symbols-master it sounds like you downloaded the symbols library from github or gitlab. You normally shouldn’t have to do that because kicad comes packages with the same libraries. But you can still add those manually but not through the plugin manager, just go to Preferences -> Manager symbol libraries... in main KiCad window and add those libs there (extract them first).

There has been some talk about adding the official libraries, maybe the development versions of them, as managed packages, but it hasn’t been realized. In normal cases you shouldn’t need to download the packages from outside KiCad because they are included through the Windows installer or as distro specific packages on Linux. If you still need the libraries as dummy downloads, do what qu1ck said, and read the FAQ section or this forum if you need info about library management. (Start Here) Frequently Asked Questions