Measuring distances/snap cursor to grid/showing grid


This is really about the footprint editor.

  1. If I make my own grid while creating a footprint to make it easier to put pads in the right position I find the cursor still moves in tiny increments.

I do Dimensions | Grid Properties

to set (in this latest case) the grid (in mm) to 1.3, 2.9

However, the cursor position still moves in 0.005mm steps! Can this be changed?

  1. From searching I believe to measure distances you have to hit space bar to set a measurement start place and then move the cursor and something will tell you the relative distance.

If I hit space bar to set the measurements to 0 in a particular place, that does bring up in the bottom of the window information telling me exactly where the pad is if I click on a pad, however, although I get x and y and dx and dy measurements changing at the bottom of the window they in no way give me the distances moved from where I hit the space bar. Also, I want the measurements to move in grid size steps. What am I missing here?

  1. The grid doesn’t show up. Even with the grid box ticked in the render tab, I get nowt! I also can’t change its colour. Are these known bugs or am I missing something?

Many thanks for your help. :slight_smile:

you need to select the user grid for the grid settings to become active
A detailed explanation is found in the Tutorial: How to make a footprint in KiCad 5.1.x (From scratch)? (section Adding the mounting pads using the user grid.)

This was the only way in version 4. Since version 5 there is a measurement tool available that gives easy to understand feedback. (left click to start, move mouse and see the tape measure, another leftclick to fix the endpoint till the next action is taken.)

Found in inspect -> measure (version 5.1)

Might be that it shows up but you do not see it. check in the preferences -> preferences -> (pcb_new/footprint editor) -> display options if you have selected dot, small cross or lines and how the thickness is set.

Yep, as I said in the original post that’s what I did. Dimension | Grid Properties. That has the user defined grid properties in it.

I’m on version 4.06, that’s the latest one in my repositories unfortunately. I did try building from source once and got precisely nowhere, so I’ll have to wait for the measurement function. I think my original question about the spacebar method still stands though.

Thanks for the reply. :slight_smile:

read my post again. You are missing an additional step!

Hint: you need to select the user grid in the list of grids. This is the same list that also holds the pre defined grids. The drop down list in the top toolbar or select it via the right click menu.
(Details in the tutorial)

1 Like

Doh! Yeah, that was what I missing! Thanks!

BTW, if I select Open GL it shows the grid. Although I can see nothing in my version about dots not grids. I don’t even have a display options in my version. Unfortunately Mageia are really slow at updating kicad. I guess not many of us Mageia users use kicad. :confused: Anyway, that’s a relaly minor niggle.

Thanks again.

My answer kind of assumed you are at least on 5.0 so yes most of it is not available for you.
I am not really able to help with v4 problems as i do no longer have it installed in a way to easily start it.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.