Mapping numeric symbol pin in footprint to non-numeric pins (S1 and S2)

In schematics, I have used the generic Connector:Conn_01x04_Male which specifies pins 1,2,3 and 4. Pin 4 I have specified as a ground in schematics.

In PCB I would like to map to connector BM03B-GHS-TBT(LF)(SN)(N) and therefore I downloaded and imported the footprint for this one from Snapeda. Imported footprint specifies pins 1,2,3, S1 and S2 where S1 and S2 would be connected in my case to ground.

To avoid warnings like “Warning: No net found for symbol J16 pin S1.” and also other way make it more clean, should I somehow edit the footprint to change “S1” in footprint naming to “4” or what would be the kicad best practice to handle a cases like this?

And what about then “S2”, could I also somehow mark that it’s also same “4” even if it’s physically in different location in footprint/real connector component?

connector_generic_symbol
connector_footprint

One solution I noticed was to just double click the S1 and S2 pads from footprint and then change for both of them the

  • “pad number” to 4
  • “net name” to GND

Another way I assume would be just to edit the whole footprint and change the “S1” and “S2” pad numbers to “4” for whole footprint.

If I would like later to submit this type of footprint to kicad library, would the library rather like to use “S1” and “S2” instead of mapping to number in this kind of cases?
(Not sure whether snapeda impored footprints are actually allowed in official kicad library)

Renaming both the S1 and S2 pads in the footprint to 4 is a solution, but remember that pads with the same number always have to be connected on the PCB.

As you’ve already downloaded this footprint form some external source, you can just load it in KiCad’s Footprint Editor to change the pad numbers (names), save the changes, and then: Schematic Editor / Tools / Update PCB from Schematic [F8]. Make sure the option Replace footprints with those specified in the schematic is on, or else KiCad will keep the old unmodified footprints on the PCB.

Alternatively, you can also use the PCB Editor / Tools / Update Footprints from Library tool to reload one or more footprints from their libraries.

Another solution might be (I would probably do it this way for the implicit documentation) to use a different symbol on the schematic. I quickly found this one:


and this one:

Choose the “proper” one depending on if the extra pins are just mounting pins embedded in a plastic housing, or are actual metal connector shield pins.

And then on the downloaded footprint change both the S1 and S2 pins to MP or SH (depending on which symbol you chose). In KiCad a pin “number” doesn’t even need to have numbers in them.

This will allow you to either connect the shield/mounting pins to GND, AGND, DGND, ChassisGND, etc. or put a no-connect on it, and when troubleshooting this board a couple years in the future when looking at J16 on the board and seeing a 3-pin connector you can find it as a 3-pin connector on the schematic.

Thank you for all of the good suggestions, I ended up using the solution which changed the symbol in schematic to one having MP pin and renaming S1 and S2 on footprint also to MP.

1 Like