Manually connecting pads in PCBNew

I’ve recently updated to 5.0 and trying to build a new board. When I make boards I usually have to manually add some pads and connect them to the circuit for connecting to external components. In V4 I could turn off ‘enforce drc’ and could just run a trace between the two components. Tried that in V5 and it won’t connect them as they’re not connected by a net.

What settings to I need to change to get it happening?

I have just tested so in v5. It works the same way as v4, disable DRC.
First icon on the left toolbar.

…or you could add Connector_Generic symbols and attach fitting footprints to them. It’s not very difficult. Either use 1pin/1 pad parts or create footprints with as many pads as needed and corresponding number of pins in the symbol. If you don’t want to do that, you can give the pad a net in the pad Properties. And if you don’t want to do even that, you can change Interactive Router Settings, Allow DRC violations and select the Highlight collisions mode.


I tried the disable DRC and it wouldn’t do it. I’ll try again when I get to the shop this morning.

It’s for legacy toolset only. Interactive Router Settings works for the modern toolset.

1 Like

I’ll give that a try. It’s mainly I’m using a 3pdt switch and 1/4 inch jacks (I sell pedalkits) and the switch just uses a single input and output to the switch as the remainder is off board.

Ok, problem solved. Turning on ‘highlight collisions’ in the interactive router settings did the job.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.