Manual routing problem


I get a problem with the new Kicad version (5.1.5-2) on Windows 10.

Usually when I routed a track to some pad, when putting the mouse close enough to the padcenter, the trace could get “locked” to the pad center (or through hole), and was coming straight, exactly aligned to that pad whatever its position.
Now the problem I have is that the last point is locked to the grid, and there is always a little airwire remaining. This wire disappears when pressing escape to terminate the trace and there is basically no electrical problem, but it doesn’t look clean.
Maybe it’s a matter of some setup. Any idea on how to fix it (except going back to an older version)?



Hi @roboya
for me its always harder to follow worded descriptions than seeing tge actual Problem. Are you able to provide us some pictures of the problem?
In this case a PCB file can also help to se if we can reproduce it. There has no real design to be in there just two footprints that can show the problem.

photos would help, but I might suggest using the “switch track posture” right click option while routing to see if that behaves more to your liking (hide the angled piece in the pad)

Magnetic pads might be turned off in the preferences dialog.


The problem is that it’s difficult to take a picture, except with a camera or full screen dump without moving the mouse. And even if I take a picture (I did), it doesn’t explain anything. I would have to take a video in this case to show the strange behavior.

Hello Rene!

You got it right. In PCB edifor: Preferences. Then in Pcbnew pane, magnetic points at the top
right of the window, then choose snap to pads -> always.
I wonder why this changed, but hey, it works.


1 Like

7 posts were split to a new topic: Creating a screencast (video of the KiCad) for sharing on this forum

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.