Managed to Lock up EESCHEMA


#1

I managed to lock up the EEschema program this afternoon. I was trying something different than I have done before so a work-around might be “don’t do that again” :slight_smile:

Anyways, here’s my system setup:

  1. Running VMware Workstation on a Windows 10 machine.
  2. The VM is running Linux Mint 18 “Sophia”.
  3. KiCAD v4.0.7 Debian install version used.
  4. Two workspaces open. One for KiCAD and one for a PDF datasheet.

Here’s what happened.

  1. I was working on a single sheet schematic in EESchema.
  2. I decided to add some I2C devices, so I formed a hierarchical schematic on my original schematic.
  3. I then selected two newly placed global label and use copy-block to place them on the clipboard (I think that is where they went, but not sure.
  4. I next went to the new hierarchical sheet where I was going to paste them to start the I2C schematic layout.
  5. EESchema froze at this point. I could operate the VMware machine but EEschema was completely hung up.
  6. I tried sending a VM ctl-alt-del to Linux Mint but go no response from Linux Mint.
  7. I was able to suspend the Linux VM, close out VMware, and reopen it.
  8. On reopening the Linux VM, the machine came up in the same locked state as before.
  9. I quit the Linux Mint VM and lost what I was doing (fortunately, only 10 minutes or so passed the last save).
  10. A _saved_KiCADprogram.sch was found and loaded with no changes lost. A error message stated that the hierarchical sheet could not be found.

I suppose the problem lies where the copy-block command has been issued, and a command to go to a hierarchical sheet occurs. Maybe the copy-block expects to do a paste-block before going to the hierarchical sheet, and this confuses the software and causes it to hang (just a guess).

This was not a huge problem for me, and the recovery was good. So a quick fix is nor necessary. Just add this info to your problem notes set in case it relates to something else more serious.

Next


#2

If you can reproduce it with the same steps it would be good to log it in the bug database (https://bugs.launchpad.net/kicad).

I tried it on a recent build and it worked fine. I did fix some bugs in Copy/Paste at the end of last year, but I already can’t remember what they were about.

If it does still reproduce for you, you might want to try the nightlies.

Cheers,
Jeff.


#3

Be careful with suggesting the use of nightly builds. (Especially to inexperienced users or to users who use kicad for production.) Always inform the user that using nightlies also comes with some dangers


#4

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.