Make Zones edge more noticeable

Maybe its just me, but the lines with show the edge of zones I can barely see. Is there any way I can set the line thickness? Its like clicking around in the dark until I eventually get lucky. Have played with the hatching options but didnt help.

1 Like

I wonder if seeing them is more about the color and the display brightness etc. The default colors in 5.1 are quite dark and difficult to discern especially if the monitor isn’t bright.

But there’s no way to change the line width.

One thing you can do is draw the edge of zones outside of your PCB, like:

When zones are hard to select, it is usually because the edge of the zone overlaps with footprints, tracks and other stuff, and having (even a small section) of the zone outline outside the PCB makes the zone easy to select. KiCad then calculates the real edge of the zone from the PCB outline (with some clearance). This clearance can be made bigger by modifying the lines on Edge.Cuts.

Instead of clicking on the edge of a zone, you can also drag a small box from right to left over the edge of a zone. This box select selects everything that is inside the box or crosses its borders.
(Drawing the box from left to right only selects fully enclosed objects).


Thank you for those great tips. The problem is sometimes I can’t see the outline of where to draw the little box. On my screen they very faint. Was hoping to be able to make them like a few pixels wide (maybe they currently only 1px wide)

For me those 1 pixel wide lines are quite good visible.

Maybe you have such an “HiDpi” monitor with very small pixels?
(For such a monitor a wider line may be useful)

Maybe you have a LCD monitor with an analog VGA connector. In that case it may help to adjust the timing of your monitor with the video signal. This can be done with the buttons on your monitor.

Or post a screenshot. I wonder if there is any significant difference between mine and yours.

I took a photo, cause I imagine a screen shot is the same regardless.

I added a green arrow to point to the keep out rule edge, you can just see it:

Heres the same view, but I presses “a” to toggle solide/outline view of the zones:

Oh flip I see the zones transparency is set to 70%. Its really nice when its poured, but very hard to see when outline mode. I upped it to 100% and now it is viewable!

I find everything in your screenshot very vague, including texts in menu’s and such.
Photographs of monitors don’t mean much. There are just too many factors added that have nothing to do with KiCad itself.

You also had not mentioned you are using KiCad-nightly V5.99 which has a completely different color scheme, and more transparency options.

You can also use more saturated colors to increase the contrast.

Screen shots mean nothing in showing how it looks to me on my screen. You can see other details in the photo, but you can’t see the zones. You can easily see the courtyards, tracks, silkscreen, but not the zones, that difference in visibility is what I was trying to show.

I changed it so that now the outlines are always drawn opaque (the transparency was really meant to apply to the filled areas, not the outlines). So, next nightly it should be better.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.