macOS, everything is white text on light gray background


#1


#2

By the looks of it you are running Mojave with dark theme. But your window caption is dark, for me Kicad windows still have light captions and system theme doesn’t seem to affect them so I don’t have this issue (I’m on 5.0.0-3 stable).
Which version are you running?


#3

Same here. :frowning: Running KiCAD 5.0.1-3 on Mac OS Mojave (Darwin 18.0.0)

Is there a possibility to fix it with the Config-File?! (kicad_common)


#4

I am having the same issue. Are there any ideas on how to fix this up?

I looked and it seems this is a core wxWindows issue with Dark Mode on OSX. Check out the following link:

https://trac.wxwidgets.org/ticket/18146


#5

SOLVED!, Kind of…

The temporary fix is to disable the dark mode for KiCad and friends. On my Mac, this is what I did:

  1. Open a terminal

  2. Go to the “/Applications/KiCad/kicad.app/Contents” directory

  3. Use a text editor (I used nano) to edit the “Info.plist” file

  4. Place the following line toward the end of the list of keys but still inside the “dict” block:

     <key>NSRequiresAquaSystemAppearance</key>           <true/>
    

That should do it. My Info.plist file is attached here: (Ok, I can’t upload because I am a new user.)

Update: I have opened a formal bug report at https://bugs.launchpad.net/kicad/+bug/1804351


#6

It works fine for me, thank you.


#7

Yes, works with Mojave and 5.0.1.3(KiCad) perfect :slight_smile:


#8

Hurrah! And it only took me 40 minutes to locate this tiny bit of information in the internet sea.
Thanks for the timely excellent solution.