Mac performance issues

I’ve been using KiCad since version 4, several years, on this same Mac.

I upgraded to 6 when the official release dropped. Before too long, I started noticing that saves on projects I was working on would take an appreciable amount of time (starting to approach a minute) even on relatively small things.

Recently being frustrated with it, I upgraded to 6.0.5 (after all 6.0.0 was sure to have some bugs, right? :smiley: ).

Not only has the problem not gotten better, but it seems to be worse. I just opened it up and tried to switch from one project to another, and it basically pegged one CPU core and sat there spinning until I did a Force Quit. And projects I have opened since upgrading to 6.0.5 have the same issue of slow saves, both from PCBNew and from EESchema.

I did just upgrade “over the top of” the 6.0.0 version. I wouldn’t expect problems from that to manifest this way though.

I’m running Catalina, 10.15.7. I have some older software packages that are likely to break if I upgrade further, and as it is this is a very old macbook pro (mid-2012), but I have upgraded the memory (16G) and am running on an SSD (Catalina and beyond will not run at any speed on a hard drive). I have multiple other large apps I run routinely, for example Photoshop, which aren’t exhibiting this sort of problem.

I’ve by no means ruled out other issues with the laptop itself, but I wanted to just ping here and see if anyone else might be seeing anything similar. A cursory search here for performance mostly comes up with prior versions…

…no kidding. Have you seen/read my posts… Here’s the last one re Mac

Different kind of Performance issue. It’s like a Band with performers too drunk to get up on stage but, in total (no matter what the issue), the ‘Performance’ is bad…

I did read through your thread, and quite honestly, I did not follow all the lines and graphs and screenshots. My brain works in a different way, I guess.

One of the respondents commented on using ls in terminal – that’s the world I’m much more familiar with.

If the assertion is that there are things that should be symlinks but are actually full folders of their own, ls -l should show this quite handily…

I use KiCad on 10.15 and don’t see these kinds of issues.

Do you notice that it happens with every project? What if you start a brand new project, do you see the same long delay when saving it? Where are you saving, on a local drive or to a network folder or some kind of cloud sync service?

1 Like

I’m also on 10.15.7. I experience annoying delays after each rebuild because Catalina waits 10 seconds before asking me if it’s OK to access downloads or some other folder, but once running it seems to be as quick as 4.0 was.

Mine’s a mid-2014 MacBook Pro with 16GB memory and SSD storage.

Oh, yes, I used Terminal to check symlinks (several commands to do this). In the end, there are handfuls of Good Links and handfuls of Bad links.

Sure, it’s not entirely a Kicad issue but, Kicad’s file system/mgt is, is, is… well, you choose the ‘Open-Source’ word to describe it… I don’t want to be rude.

My point (though perhaps ‘un-said’) is this: Monterey is buggy (so was Catalina so I blew it away and went back to High Sierra). Only reason I upgraded to Monterey was to:
Run Kicad 6.0.x and CleanMyMacX updgrade.

I regret upgrading to Monterey. It’s not ready for Prime-Time… If they keep marching down the California coast, I expect to see a Good OSX by the time it gets to San Diego :rofl:

And, I regret upgrading Kicad to 6.0.x

@craftyjon yes, This happens even on new projects. The one I was opening that caused the whole thing to hang was one I just set up this past week.

I’m saving to the local SSD, no networking involved. I don’t even have Google Drive or Dropbox set up to sync with these folders.

@JeffYoung Yah, I’m familiar with that, but I’m not doing nightlies, so after the first time it prompted me, it hasn’t since (well, when I went to 6.0.5 from 6.0.0 I think I got the prompt again one time).

Unfortunately I have apps that won’t run prior to Catalina just like I have apps that won’t run on the latest and greatest (and kudos to Apple for making it bloody difficult to upgrade to any intermediate version).

So I clearly don’t have Monterey’s filesystem issues. I haven’t experienced an awful lot of bugs in Catalina.

I’m quite open to the idea that there’s something unique to my system other than KiCad that is causing this, but I really do expect that I should see signs of it in other apps besides KiCad if that were the case.

Do you know how to run gdb? It would be interesting to know where it’s spending the time when it locks up…

(Note that you’d need a version with debug symbols or gdb’s backtrace won’t tell us much.)

I’m not familiar with gdb per se, but I have done kernel level debugging in Solaris in the past, so I at least know the ideas. Are the nightlies built with debug? I assume I could move the main release version “aside” and install the nightlies temporarily? Or are they likely to make project changes that don’t let me go back to the main release until that catches up with whatever version I’ve installed?

All of that said, I think I have recognized something.

I run a LOT of chrome tabs and some separate windows. Yesterday I tried killing chrome entirely, and starting kicad on its own, and there wasn’t a problem, even with projects that had been an issue previously. I also then started chrome a little bit later, re-opening all the tabs, and KiCad continued to be fine.

I suspect that since most of the time I am starting KiCad with chrome already running, that it’s memory starved because chrome is such a pig. Even with 16G system RAM. :face_with_raised_eyebrow:

I can’t say about Mac, but on this Linux box Firefox gets choked by some tabs, but not with memory. I presume there are buggy javascript pages which get into some loop. You should use some process manager to see if it’s memory or processor time or maybe something else.

Firefox absolutely chokes on some tabs for me but the rest of the system remains unaffected. I’ve taken to running top in the background sometimes. Seems whenever my fan speed kicks up indicating work load increase it is browser related. Even simple security settings are getting cumbersome on my older system.

@elmegil I’m not familiar with Mac but I’m sure there is some sort of performance monitoring built in.

I’ve definitely had cases where Safari has chewed up enough memory that other apps had to keep paging memory. That shouldn’t be catastrophic with a SSD, but it’s still going to slow things down considerably.

Yup, that would be a major problem. Flipping memory pages between storage and RAM is expensive.

The other part of that which makes sense is if I save and wait, and then make a minor change, and save again, the second time it’s reasonably fast. Exactly the symptom I’d expect if there was memory pressure causing me to page in and out.

Next time it happens I will go spelunking to see if I can verify this hypothesis, but at the moment it seems the most likely cause, and not KiCad’s fault at all.