Mac OSX 10.10.5, KiCad 4.00 Stable crashing pcbnew & footprint editor

First off, first post, actually first time even in these forums. I’ve found similar questions, but one was for Windows 8 and one was a year old.

It’s been close to a year since I’ve even opened KiCad, I’ve moved to a different mac which has never had it installed on it. I downloaded from version 4.0.0 stable release, installed it and ran the schematic editor, which worked fine. My problem is when ever I try to launch Pcbnew or footprint editor it immediately crashes. I’ve tried completely blank projects and it crashes every time.

I did find some references to ‘boost’ causing crashes when there are multiple versions on a system, could this be the issue I’m experiencing? I did a long time back do a full build of Mac Kicad (before there was an installer available on the site) but it was on a different system, and I remember it being a little trial and error getting the build to complete so I’d prefer to avoid that all together… my development days are over (I’m an old fart).

I also noticed that there is a 4.0.1 stable release but haven’t seen it yet for the Mac, and not ever sure the changes are related to mac OS versions. If anyone has suggestions, I’m open to trying anything cause as it stands KiCad is unusable and I’ve had to move back to using my DipTrace license.

If you require any additional info let me know and I’ll post a followup. Any other Mac users having this issue - Yosemite, not El Capitan as my Mac Pro doesn’t support the upgrade ;-( Thanks.

Ok, I’ll definitely give this a go, see how it goes.

Thanks Andy

UPDATE: Perfect back in business - used the Dec 20 build. Thanks again Andy.

Same problem on MacBook 7,1, OSX 10.9.5.
Nightly build (kicad-r6390.20151220-225435) is working, thank you! :slight_smile:

Yes, saw that file this morning while looking around on the site. Sooo, I already downloaded
but haven’t had a chance to install. I’m sure all will be fine. Much appreciated for the heads-up.

EDIT: Perfect all works great - few errors about footprints, so I installed KiCad Extras to keep the
footprints local, all errors are gone.