[Mac OS X] Hierarchy label and pins

Dear Kicad forum

i am a beginner in this kicad schematic design
assume i will use flat flat hierarchy

i have few questions about the schematic tool

  1. how can i connect VDD_5V,SYS_5V to multiple pins in multiple pages in the schematics. now there is something called global label can i not achieve this without a global label this global label size is pretty big box makes design look pretty messy so i just wanted some 2 arrows for gloabl label just like “>>” for output and “<<” for input can i not achieve this.

  2. I am unable to copy a block from root schematic to a hierarchical schematic which is inside root. can some someone let me how this can be achieved.
    there is an option called save block and copy block i cannot achieve copy paste using any of these keys
    copy block only works within a schematic not between schematics this happens on Mac OS X el capitan.


When you place global label edit the size to made it smaller. The default value is 0,060" and might look bigger. Using 0,030" the label and his graphics will be ~50% smaller.

Use specific block operation:

  • Start a block operation with left mouse button down.
  • Select area.
  • Keep holding left mouse down, click right mouse button for context menu.
  • From this menu select “Save block (Ctrl-C)”.
  • Enter the subsheet.
  • When you’re ready do paste this block somewhere click “Paste” on top toolbar.
  • Click LMB where you want to place this block.

This procedure works between schematic too, even from different projects, but you can not close Eeschema and you have to start Eeschema directly not from project manager window. In standalone mode Eeschema enables the possibility to load any schematic.



the global labels are standard size they cannot be edited i think i tried all options it does not work.

the Ctrl-C option also does not work because once i select a block of circuit diagram the copy option gets disable this is the bug in the tools i spent almost 8 hours trying to figure out the copy option but i am sure it is a bug in the software. or it is a bug in the latest version of Os X el capitan. i don’t know but it is a bug for sure.

Can some one please fix the copy a block of components/circuits from a root schematic to a hierarchal schematics and vice a versa. for sure this is a BIG bug in software tool with Os X el capitan(Mac OS) or at least provide me a source code for the software tool i can fix it and release you guys a patch.

My version of Kicad is 4.0.1 which is the latest release.

application: kicad
Version: 4.0.1-stable release build
wxWidgets: Version 3.0.2 (debug,UTF-8,compiler with C++ ABI 1002,GCC 4.2.1,STL containers,compatible with 2.8)

also if possible please edit the graphic style and size of global label to look like a straight line with 2 arrows pointing inwards and the name of label


Did you try this?

Thanks Keruseykaru
yes the same thing i cannot see such size option in case of kicad 4.0.1 for Mac OS now i dont know how shall i attach a snapshot please wait i will attach a snapshot in few minutes

here you go

additionally i am attaching a toolbar in this the copy, cut option is permanently disable when i select a circuit or group of circuit it is only alive for very few microseconds may be a 100 microseconds and then it is disabled not allowing to do a copy of even right click selecting save block(cmd+c) or control+c or copy block has no impact.

I am for now not worried about the fonts of global label but i am more concerned about copy and paste block of circuits/components from one schematic sheet to another as i spent nearly 8 hours to figure out that option finally realised its a #BIG bug can some one please fix this because i had to redraw entire schematics all over again can you please imagine redrawing again from scratch.

Do you have a Retina display? If yes, try to setup Low Resolution mode for KiCad applications.

hello keruseykaryu

it is a bug anyway that is not important for me i can survive with bigger fonts

but the big concern is copy paste option does not work which is a bug as well?

just for your info i tried with all resolutions nothing helps.

Did you file a bug report for the ‘size’ field missing on the label properties dialog?
Stuff like this should be fixed pretty fast I think as it’s just some values in a GUI framework that need adjusting…

Afaik (might be 100% wrong here) this only works when you start eeschema (or pcbnew) stand alone - not via KiCAD toolbar.
You have to start them from the binary folder, so they are not part of a project… then you should be able to copy blocks/etc

That is in case of copying between different schematic. Inside one project the block copy/paste works properly, at least on Windows and Linux platforms. I can not setup virtual machine to start any Hackintosh - CPU limits - to check it.

Nick could you describe in details - step by step - how do you try to copy your schematic between subsheets? Maybe you missing some important step.

Obviously only context menu doesn’t work correct.
It works if
(1) Select block
(2) Press Cmd-C
(3) Goto hierarchical sheet
(4) Paste…

Please file a bug report for the non-working context menu as already said above.

ok the way i am doing a copy paste i have explain here.

i have a root schematic sheet it has 3 sub schematic sheet

now lets say by accident i draw a circuit on the root sheet later i realised it must be in one of the sub shematic sheets inside the root now all i am trying to do is copy a circuit from root sheet into sub schematic sheet and all of it belongs to the same project.

steps i followed:
method 1

  1. select the component using arrow key and right click select save block.
  2. go inside any schematic sheet select paste option from the tool bar does not work.

method 2

  1. select the component using arrow key and right click select copy block
  2. go inside any schematic sheet select paste option from the tool bar does not work.

now the options of copy on the toolbar cannot be selected because if i try to go there after selecting a component i wont be reaching there at all because i end up dragging component inside/outside schematic sheet infinitely.
also i can see that option disabled permanently immaterial of whatever i do i have attached screen shot for some simple component.

thanks in advance for any help

As I said in my post… it doesn’t work for me either when I try to use right-click=>context menu=>Save Block. That’s clearly some bug. This context menu entry seems to be just ignored.

Select your components and then press Cmd-C instead of trying to use context menu.
This works and you will also see that the toolbar icon for paste will get enabled then.

Unfortunately, CMD-C is reliably unreliable. See bug 1420714

thanks guys

i have raised a bug https://bugs.launchpad.net/kicad/+bug/1551063

but this should be very easy to fix if some can please share the source code i can fix it as it is just simple update directory structure.