Mac OS Catalina Installation

Hi all, sorry for first post being a ‘Help I’m a noob’ question… but I’ve tried the FAQ, Googling, Youtube vids, and nothing seems to be helping my plight. I’m on OS X Catalina. I followed the install instructions, but can’t seem to get any of the symbols or anything. So far I’ve tried:

Moving application support files to ~/Library/Application Support/kicad
Copying application support files to both locations
Changing locations in Paths

No matter what I try, I get no symbols - not a single one. ‘Choose Symbol’ dialog says ‘0 Items Loaded’

What am I missing? TIA :slight_smile:

For symbols to be loaded there are 2 conditions:

  1. They must be on your disk or some mounted filesystem somewhere
  2. There must be entries in your global or project symbol table pointing to the location of symbols on your filesystem

Default installation on a clean system helps create a global table that has all entries for default libraries. If your system already has an empty global library table the dialog to choose that option on first run of kicad will not pop up. It’s an easy fix though, just open symbol library manager from kicad main window and add those libraries manually.
Read this for more info Library management in KiCad version 5

1 Like

Thanks for the reply. The ‘default’ installation on this particular Mac just seems problematic. The files are there, they just don’t seem to be being picked up. I subsequently performed the installation on a Mac with a newer version of the OS and it worked absolutely fine.

I’ve tried removing all trace of the installation and starting it again, but it appears to pick up all the pre-existing settings. I simply can’t get it working no matter what I try. I went through the Library Management link you sent and can’t see anything I have not already tried. There seems to be no way of resetting everything to default, or whatever. Any ideas?

The first time you start KiCad after installing, it asks you if you want to create the library tables. If you answer no to that question, then KiCad assumes you want to do this manually and it does not generate those tables.

KiCad does not search for libraries. So without those files then you simply can not use any of the libraries in KiCad.

Did you do:

Resetting the library tables to default settings

from the library management link qu1ck posted?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.