Lost Some 3d components


#1

Hi,
I’ve been away for a month and when I installed the 6-28 nightly (kicad-r10587.0748c118d-x86_64) I lost the SMD resistors, capacitors and transistors. I still have the one thru hold device (a connector).
I can see the 3D parts in “3D settings” in PCBnew but they are not rendering with alt-3.

Have I missed something? The libraries are in a non standard location but all still there and the paths are all correct (I don’t use environment variables).
Thanks
John


#2

Open a footprint’s properties directly from a problematic board (not from the library). Show us the 3D file path. Check the file.


#3

I assume the project in question has been created with an old nightly or even with kicad version 4. The library has since been reorganized. Meaning the footprints cached in the pcb_new file will point to no longer existing 3d models. (As they have been renamed to fit the new footprint names)

My suggestion would be to install the version 4.0.7 library in addition to the version 5 library and switch between them as required. (the version 4 lib for old projects, the version 5 lib for new ones.)


It might also be that kicad is still setup to use the online version 4 footprint library. If you had kicad installed before the switch to the new library was made this will be the case. (you can check this via the library wizard of pcb_new)
If there are libs in there that use plural library names and their path starts with {KIGITHUB} then this is the case.
In that case you have two options.

  • Switch over to the version 5 lib (means add the already locally installed footprint libs instead of the online version 4 footprints to the fp-lib-table.)
    • Easiest option is to delete your personal fp-lib-table as kicad will overwrite it with the system version as soon as your run for example the footprint editor.
    • Or if you have personal libs in the fp-lib-table you can replace the old entries of the official lib using the library wizard or a text editor.
    • More details about installing a specific version of the official library: How can i install a specific version of the footprint library?
  • Switch back to the version 4 library (Not recommended)
    • In that case you can leave the footprint side of things untouched. But you will need to manually install the version 4 symbol and 3d model libraries.
    • This would mean manually download the content of the old kicad-library repo, extract it to any place of your liking and use the library manager of eeschema to setup kicad to the library folder contained in it.
    • In addition you would need to setup KISYS3DMOD to point to the 3d model library also found in that download. (It is in the modules/packages3d folder)

#4

Thanks for all the responses. I should have mentioned the board was created on a window10 machine that never had 4.0.7.

The Libraries were downloaded some months ago (April 2018) from the V5 libs area of Kicad. There has been no change to the libraries since then. The github path has been altered so no downloads from github are possible.

Attached is a screenshot showing part of the board, the component window and lib path. I checked with explorer and the file is indeed there.

I also used the “update footprints from library” tool from PCBnew with no change.

capture_002_29062018_113044

Thanks
John


#5

I think the 3d viewer has some controls for what to show.
In kicad 4.x it was under preferences->show 3d models. (3 options back then where normal, normal + insert and virtual.) As i do not have access to a newer nightly at this pc i can not check how it is called in current nightlies. (I would guess the new options might be called THT, SMD and virtual.)


#6

Here is the display options window from a fairly recent (like in the past day or two) nightly on Win10.

2018-06-29%2011_56_29-3D%20Display%20Options

The controls @Rene_Poschl mentions are here, accessed through the Preferences/Display Options menu in the 3D viewer:
2018-06-29%2011_59_43-3D%20Viewer

Also on the tool bar of the 3D viewer:
2018-06-29%2011_59_56-3D%20Viewer

Hope this helps.


#7

Bingo! Found it. And as I was afraid of it was …duh moment. I had looked at the box but my focus did not drop below the rendering options.

Still not clear how the ckeck box became unchecked.

Thanks for the support.

John