Logo placed on the PCB, does not plot

I have a PNG image that I would like to place on the front copper layer of the PCB. I have largely followed instructions here: http://www.lemongrass-studio.net/main/node/151, using bitmap to component converter to create a library with the image. I added the library to the project, and in the PCB editor added the logo to the board using “Add footprints” button. Before adding the library, I manually edited the *mod file and changed F.SilkS to F.Cu everywhere. I have copper fill on both sides of the board, and I created an exclusion zone under the logo image. Everything looked well, but when plotting, I see an exclusion zone and no image. Are there any obvious steps I could be missing? Will be happy to post more information and details if necessary. Thanks!

It seems your workflow is correct.

I would try to create the gerber files and see if the logo is present or not.

As the zone will have a clearance around the logo, I would try without the keepout zone too.

If you want, you can share the logo footprint so some of us could test it.

You gave me an idea, thanks. I created a plot of all levels to see if the image shows on any of them. For some reason, I found it on the Eco2-User layer. I poked around, but cannot figure out how to force it to appear on the front copper.

If you look at the Bitmap to Component Converter user interface you can see that it lets you select the layer, but only some of the layers are enabled for some reason. A place for bug report?

KiCad still can’t change the layer of several items at once. You have to change it one by one if you image has been converted to several graphic items. Or you can install the “move to layer” plugin from https://github.com/easyw/kicad-action-tools/ which can change the layer of all of them at once.

Looks like as a new user I am restricted from uploading attachments. Here is a sample I’ve been working on (google drive link): https://drive.google.com/open?id=11omIaLIgGX_jSD23qZ5LxxfFk5_CRr9S


If your final image is that or like that you’re lucky: you can select the graphics polygon in the footprint editor, open Properties and change the layer.

Excellent, that indeed worked. Thank you! I guess if the final image consists of a few disconnected components, I would have to repeat above procedure for each component? I clicked on a component, then right-clicked and chose graphics polygon.

That’s what I meant in my first message - KiCad doesn’t handle that for group selection natively (yet).

I just remembered that plugins can’t be used in the footprint editor and you can’t select footprint’s graphics in the board editor, so the plugin doesn’t work for footprints. In this case a text editor would work fine - just find&replace Eco2.User with F.Cu in the footprint file.

Indeed replacing Eco2.User with F.Cu worked perfectly. Thank you so much for the help!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.